# CVE-2022-29179: Improper Privilege Management in Cilium

> An attacker with root access in a container can escalate privileges to cluster admin via Cilium's Kubernetes service account.

- **Severity:** High 7.5 (`CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 May 2022
- **Updated:** 23 Apr 2025
- **Also known as:** BIT-cilium-2022-29179, BIT-cilium-operator-2022-29179, BIT-cilium-proxy-2022-29179, BIT-hubble-2022-29179, BIT-hubble-relay-2022-29179, BIT-hubble-ui-2022-29179, BIT-hubble-ui-backend-2022-29179, GHSA-fmrf-gvjp-5j5g, GO-2022-0458

## What is CVE-2022-29179?

CVE-2022-29179 is a high-severity vulnerability in cilium, published on 20 May 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Cilium is open source software for providing and securing network connectivity and loadbalancing between application workloads. Prior to versions 1.9.16, 1.10.11, and 1.11.15, if an attacker is able to perform a container escape of a container running as root on a host where Cilium is installed, the attacker can escalate privileges to cluster admin by using Cilium's Kubernetes service account. The problem has been fixed and the patch is available in versions 1.9.16, 1.10.11, and 1.11.5. There are no known workarounds available.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2022-29179?

14 open source packages ship an affected version, including github.com/cilium/cilium, cilium and cilium-operator. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/cilium/cilium` | Go | All versions | 1.9.16, 1.10.11, 1.11.5 |
| `github.com/cilium/cilium` | Go | All versions | 1.9.16 |
| `github.com/cilium/cilium` | Go | All versions | 1.9.16 |
| `github.com/cilium/cilium` | Go | From 1.10.0 | 1.10.11 |
| `github.com/cilium/cilium` | Go | From 1.10.0 | 1.10.11 |
| `github.com/cilium/cilium` | Go | From 1.11.0 | 1.11.5 |
| `github.com/cilium/cilium` | Go | From 1.11.0 | 1.11.5 |
| `cilium` | Bitnami | All versions | 1.9.16, 1.10.11, 1.11.5 |
| `cilium-operator` | Bitnami | All versions | 1.9.16, 1.10.11, 1.11.5 |
| `cilium-proxy` | Bitnami | All versions | 1.9.16, 1.10.11, 1.11.5 |
| `hubble` | Bitnami | All versions | 1.9.16, 1.10.11, 1.11.5 |
| `hubble-relay` | Bitnami | All versions | 1.9.16, 1.10.11, 1.11.5 |
| `hubble-ui` | Bitnami | All versions | 1.9.16, 1.10.11, 1.11.5 |
| `hubble-ui-backend` | Bitnami | All versions | 1.9.16, 1.10.11, 1.11.5 |

Products: Cilium Cilium.

## How do I fix CVE-2022-29179?

Upgrade github.com/cilium/cilium to a fixed version for your release line: 1.9.16, 1.10.11 or 1.11.5.

## Is CVE-2022-29179 being exploited?

There is no known exploitation of CVE-2022-29179 in the wild and no public exploit code.

## Other vulnerabilities in cilium

- [CVE-2026-49445](https://insights.sbomify.com/CVE-2026-49445/): Cilium: Sensitive information disclosure and cluster disruption via local Envoy admin socket access (critical 9.2)
- [CVE-2022-29178](https://insights.sbomify.com/CVE-2022-29178/): Incorrect Default Permissions in Cilium (high 8.8)
- [CVE-2024-28860](https://insights.sbomify.com/CVE-2024-28860/): Insecure IPsec transport encryption in Cilium (high 8.0)
- [CVE-2026-41520](https://insights.sbomify.com/CVE-2026-41520/): Cillium exposes sensitive information included in the cilium-bugtool debug archive (high 7.9)
- [CVE-2024-37307](https://insights.sbomify.com/CVE-2024-37307/): Cilium leaks sensitive information in cilium-bugtool (high 7.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-29179 and fix it if it is affected.

What it is: CVE-2022-29179 is a high-severity vulnerability in cilium, published on 20 May 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-29179 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/cilium/cilium (Go): affected all versions; fixed in 1.9.16, 1.10.11, 1.11.5
- github.com/cilium/cilium (Go): affected all versions; fixed in 1.9.16
- github.com/cilium/cilium (Go): affected all versions; fixed in 1.9.16
- github.com/cilium/cilium (Go): affected from 1.10.0; fixed in 1.10.11
- github.com/cilium/cilium (Go): affected from 1.10.0; fixed in 1.10.11
- github.com/cilium/cilium (Go): affected from 1.11.0; fixed in 1.11.5
- github.com/cilium/cilium (Go): affected from 1.11.0; fixed in 1.11.5
- cilium (Bitnami): affected all versions; fixed in 1.9.16, 1.10.11, 1.11.5
- cilium-operator (Bitnami): affected all versions; fixed in 1.9.16, 1.10.11, 1.11.5
- cilium-proxy (Bitnami): affected all versions; fixed in 1.9.16, 1.10.11, 1.11.5
- hubble (Bitnami): affected all versions; fixed in 1.9.16, 1.10.11, 1.11.5
- hubble-relay (Bitnami): affected all versions; fixed in 1.9.16, 1.10.11, 1.11.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-29179/ (Markdown: https://insights.sbomify.com/CVE-2022-29179/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-29179
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-29179
- OSV: https://osv.dev/vulnerability/CVE-2022-29179

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-29179/
Summaries are generated and may contain mistakes; the official description above is the record.
