{"answers":{"affected":"2 open source packages ship an affected version, including nokogiri. It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-29181 exists.","fix":"Upgrade nokogiri to 1.13.6 or later.","what":"CVE-2022-29181 is a high-severity memory corruption vulnerability in Apple Macos, published on 20 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-29181 and fix it if it is affected.\n\nWhat it is: CVE-2022-29181 is a high-severity memory corruption vulnerability in Apple Macos, published on 20 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-29181 exists.\n\nAffected packages and fixed versions:\n- nokogiri (RubyGems): affected all versions; fixed in 1.13.6\n- nokogiri (RubyGems): affected all versions; fixed in 1.13.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-29181/ (Markdown: https://insights.sbomify.com/CVE-2022-29181/index.md)","id":"CVE-2022-29181","markdown":"https://insights.sbomify.com/CVE-2022-29181/index.md","name":"CVE-2022-29181","record":{"aliases":["DEBIAN-CVE-2022-29181","GHSA-xh29-r2w5-wx8m","MGASA-2022-0200","UBUNTU-CVE-2022-29181"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby XML/HTML library","requires_auth":"none","summary":"Attackers can cause crashes or read unrelated memory in Nokogiri by providing untrusted inputs to SAX parsers without proper type checking.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"macos","vendor":"apple"},{"product":"nokogiri","vendor":"nokogiri"}],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-843","name":"Access of Resource Using Incompatible Type"},{"id":"CWE-241","name":"Improper Handling of Unexpected Data Type"}],"description":"Nokogiri is an open source XML and HTML library for Ruby. Nokogiri prior to version 1.13.6 does not type-check all inputs into the XML and HTML4 SAX parsers, allowing specially crafted untrusted inputs to cause illegal memory access errors (segfault) or reads from unrelated memory. Version 1.13.6 contains a patch for this issue. As a workaround, ensure the untrusted input is a `String` by calling `#to_s` or equivalent.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Improper Handling of Unexpected Data Type in Nokogiri","id":"CVE-2022-29181","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"apple:macos","products":["apple:macos"],"type":"memory_corruption","year":"2022"},"n_packages":2,"n_references":5,"next":{"headline":"DOM-based XSS in GoCD","id":"CVE-2022-29182"},"packages":[{"ecosystem":"RubyGems","fixed":["1.13.6"],"introduced":["0"],"last_affected":[],"package":"nokogiri","purl":null,"source":"GHSA-xh29-r2w5-wx8m"},{"ecosystem":"RubyGems","fixed":["1.13.6"],"introduced":["0"],"last_affected":[],"package":"nokogiri","purl":"pkg:gem/nokogiri","source":"GHSA-xh29-r2w5-wx8m"}],"prev":{"headline":"Charm vulnerable to server-side request forgery (SSRF)","id":"CVE-2022-29180"},"products":["nokogiri"],"published":"2022-05-20","related":[{"cvss_score":9.8,"headline":"Apple macOS Improper Authentication","id":"CVE-2026-65400","kev_date_added":"2026-08-18","published":"2026-08-06"},{"cvss_score":10,"headline":"Security feature bypass in macOS","id":"CVE-2024-44146","kev_date_added":null,"published":"2024-09-16"},{"cvss_score":10,"headline":"Security feature bypass in macOS","id":"CVE-2024-44148","kev_date_added":null,"published":"2024-09-16"},{"cvss_score":10,"headline":"Security feature bypass in macOS","id":"CVE-2023-38586","kev_date_added":null,"published":"2023-09-26"},{"cvss_score":10,"headline":"Security feature bypass in macOS","id":"CVE-2023-40455","kev_date_added":null,"published":"2023-09-26"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-1999-0590","kev_date_added":null,"published":"2000-02-04"},{"cvss_score":9.8,"headline":"Memory corruption in macOS","id":"CVE-2026-84520","kev_date_added":null,"published":"2026-09-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-27","vendors":["sparklemotion"]},"summary":"Attackers can cause crashes or read unrelated memory in Nokogiri by providing untrusted inputs to SAX parsers without proper type checking.","url":"https://insights.sbomify.com/CVE-2022-29181/"}