# CVE-2022-29181: Improper Handling of Unexpected Data Type in Nokogiri

> Attackers can cause crashes or read unrelated memory in Nokogiri by providing untrusted inputs to SAX parsers without proper type checking.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 May 2022
- **Updated:** 27 May 2025
- **Also known as:** DEBIAN-CVE-2022-29181, GHSA-xh29-r2w5-wx8m, MGASA-2022-0200, UBUNTU-CVE-2022-29181

## What is CVE-2022-29181?

CVE-2022-29181 is a high-severity memory corruption vulnerability in Apple Macos, published on 20 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Nokogiri is an open source XML and HTML library for Ruby. Nokogiri prior to version 1.13.6 does not type-check all inputs into the XML and HTML4 SAX parsers, allowing specially crafted untrusted inputs to cause illegal memory access errors (segfault) or reads from unrelated memory. Version 1.13.6 contains a patch for this issue. As a workaround, ensure the untrusted input is a `String` by calling `#to_s` or equivalent.

Weakness: CWE-843 (Access of Resource Using Incompatible Type), CWE-241 (Improper Handling of Unexpected Data Type)

## Which versions are affected by CVE-2022-29181?

2 open source packages ship an affected version, including nokogiri. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nokogiri` | RubyGems | All versions | 1.13.6 |
| `nokogiri` | RubyGems | All versions | 1.13.6 |

Products: Apple Macos, Nokogiri Nokogiri.

## How do I fix CVE-2022-29181?

Upgrade nokogiri to 1.13.6 or later.

## Is CVE-2022-29181 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-29181 exists.

## Other vulnerabilities in Apple Macos

- [CVE-2026-65400](https://insights.sbomify.com/CVE-2026-65400/): Apple macOS Improper Authentication (critical 9.8, exploited in the wild)
- [CVE-2024-44146](https://insights.sbomify.com/CVE-2024-44146/): Security feature bypass in macOS (critical 10.0)
- [CVE-2024-44148](https://insights.sbomify.com/CVE-2024-44148/): Security feature bypass in macOS (critical 10.0)
- [CVE-2023-38586](https://insights.sbomify.com/CVE-2023-38586/): Security feature bypass in macOS (critical 10.0)
- [CVE-2023-40455](https://insights.sbomify.com/CVE-2023-40455/): Security feature bypass in macOS (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-29181 and fix it if it is affected.

What it is: CVE-2022-29181 is a high-severity memory corruption vulnerability in Apple Macos, published on 20 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-29181 exists.

Affected packages and fixed versions:
- nokogiri (RubyGems): affected all versions; fixed in 1.13.6
- nokogiri (RubyGems): affected all versions; fixed in 1.13.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-29181/ (Markdown: https://insights.sbomify.com/CVE-2022-29181/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-29181
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-29181
- OSV: https://osv.dev/vulnerability/CVE-2022-29181

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-29181/
Summaries are generated and may contain mistakes; the official description above is the record.
