CVE-2022-29182 DOM-based XSS in GoCD

Medium 4.3 Published Updated

Attackers can execute malicious scripts in GoCD users' browsers via DOM-based XSS, potentially stealing session cookies or executing code.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2022-29182?

CVE-2022-29182 is a medium-severity cross-site scripting vulnerability in gocd, published on 20 May 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

GoCD is a continuous delivery server. GoCD versions 19.11.0 through 21.4.0 (inclusive) are vulnerable to a Document Object Model (DOM)-based cross-site scripting attack via a pipeline run's Stage Details > Graphs tab. It is possible for a malicious script on a attacker-hosted site to execute script that will run within the user's browser context and GoCD session via abuse of a messaging channel used for communication between with the parent page and the stage details graph's iframe. This could allow an attacker to steal a GoCD user's session cookies and/or execute malicious code in the user's context. This issue is fixed in GoCD 22.1.0. There are currently no known workarounds.

Weakness: CWE-79

Which versions are affected by CVE-2022-29182?

It affects 1 product.

Products include Thoughtworks Gocd.

How do I fix CVE-2022-29182?

No fix has been published for CVE-2022-29182 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2022-29182 being exploited?

There is no known exploitation of CVE-2022-29182 in the wild and no public exploit code.

Sources

Also known as GHSA-qcg6-4q44-3589.

Is CVE-2022-29182 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free