# CVE-2022-29182: DOM-based XSS in GoCD

> Attackers can execute malicious scripts in GoCD users' browsers via DOM-based XSS, potentially stealing session cookies or executing code.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 20 May 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-qcg6-4q44-3589

## What is CVE-2022-29182?

CVE-2022-29182 is a medium-severity cross-site scripting vulnerability in gocd, published on 20 May 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

GoCD is a continuous delivery server. GoCD versions 19.11.0 through 21.4.0 (inclusive) are vulnerable to a Document Object Model (DOM)-based cross-site scripting attack via a pipeline run's Stage Details > Graphs tab. It is possible for a malicious script on a attacker-hosted site to execute script that will run within the user's browser context and GoCD session via abuse of a messaging channel used for communication between with the parent page and the stage details graph's iframe. This could allow an attacker to steal a GoCD user's session cookies and/or execute malicious code in the user's context. This issue is fixed in GoCD 22.1.0. There are currently no known workarounds.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-29182?

It affects 1 product.


Products: Thoughtworks Gocd.

## How do I fix CVE-2022-29182?

No fix has been published for CVE-2022-29182 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-29182 being exploited?

There is no known exploitation of CVE-2022-29182 in the wild and no public exploit code.

## Other vulnerabilities in gocd

- [CVE-2021-43290](https://insights.sbomify.com/CVE-2021-43290/): Path traversal in n/a (critical 9.8)
- [CVE-2021-44659](https://insights.sbomify.com/CVE-2021-44659/): Server-side request forgery in n/a (critical 9.8)
- [CVE-2024-56320](https://insights.sbomify.com/CVE-2024-56320/): GoCD vulnerable to admin privilege escalation by a malicious internal/existing authenticated user (critical 9.4)
- [CVE-2022-39311](https://insights.sbomify.com/CVE-2022-39311/): Compromised agents may be able to execute remote code on GoCD Server (critical 9.1)
- [CVE-2022-29184](https://insights.sbomify.com/CVE-2022-29184/): Command Injection/Argument Injection in GoCD (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-29182 and fix it if it is affected.

What it is: CVE-2022-29182 is a medium-severity cross-site scripting vulnerability in gocd, published on 20 May 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-29182 in the wild and no public exploit code.

Affected product: gocd. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-29182/ (Markdown: https://insights.sbomify.com/CVE-2022-29182/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-29182
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-29182
- OSV: https://osv.dev/vulnerability/CVE-2022-29182

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-29182/
Summaries are generated and may contain mistakes; the official description above is the record.
