# CVE-2022-29185: Observable Timing Discrepancy in totp-rs

> An attacker with prior knowledge of the password could potentially guess TOTP tokens via timing side-channels in the totp-rs library.

- **Severity:** Medium 4.2 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 May 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-8vxv-2g8p-2249, RUSTSEC-2022-0018

## What is CVE-2022-29185?

CVE-2022-29185 is a medium-severity vulnerability in constantoine totp-rs, published on 20 May 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

totp-rs is a Rust library that permits the creation of 2FA authentification tokens per time-based one-time password (TOTP). Prior to version 1.1.0, token comparison was not constant time, and could theorically be used to guess value of an TOTP token, and thus reuse it in the same time window. The attacker would have to know the password beforehand nonetheless. Starting with patched version 1.1.0, the library uses constant-time comparison. There are currently no known workarounds.

Weakness: CWE-208 (Observable Timing Discrepancy), CWE-203 (Observable Discrepancy)

## Which versions are affected by CVE-2022-29185?

3 open source packages ship an affected version, including totp-rs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `totp-rs` | crates.io | All versions | 1.1.0 |
| `totp-rs` | crates.io | All versions | 1.1.0 |
| `totp-rs` | crates.io | From 0.0.0-0 | 1.1.0 |

Products: Totp-Rs Project Totp-Rs.

## How do I fix CVE-2022-29185?

Upgrade totp-rs to 1.1.0 or later.

## Is CVE-2022-29185 being exploited?

There is no known exploitation of CVE-2022-29185 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-29185 and fix it if it is affected.

What it is: CVE-2022-29185 is a medium-severity vulnerability in constantoine totp-rs, published on 20 May 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-29185 in the wild and no public exploit code.

Affected packages and fixed versions:
- totp-rs (crates.io): affected all versions; fixed in 1.1.0
- totp-rs (crates.io): affected all versions; fixed in 1.1.0
- totp-rs (crates.io): affected from 0.0.0-0; fixed in 1.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-29185/ (Markdown: https://insights.sbomify.com/CVE-2022-29185/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-29185
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-29185
- OSV: https://osv.dev/vulnerability/CVE-2022-29185

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-29185/
Summaries are generated and may contain mistakes; the official description above is the record.
