CVE-2022-29204 Missing validation causes denial of service in TensorFlow via `Conv3DBackpropFilterV2`

Medium 5.5 Published Updated

Attackers can cause a denial of service in TensorFlow by providing invalid input to UnsortedSegmentJoin, triggering an assertion failure.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2022-29204?

CVE-2022-29204 is a medium-severity denial of service vulnerability in Google Tensorflow, published on 20 May 2022. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

TensorFlow is an open source platform for machine learning. Prior to versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4, the implementation of `tf.raw_ops.UnsortedSegmentJoin` does not fully validate the input arguments. This results in a `CHECK`-failure which can be used to trigger a denial of service attack. The code assumes `num_segments` is a positive scalar but there is no validation. Since this value is used to allocate the output tensor, a negative value would result in a `CHECK`-failure (assertion failure), as per TFSA-2021-198. Versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4 contain a patch for this issue.

Weakness: CWE-20, CWE-191

Which versions are affected by CVE-2022-29204?

22 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 1 product.

PackageAffectedFixed in
tensorflow BitnamiFrom 1.15.02.6.4, 2.7.2, 2.8.1
tensorflow PyPIAll versions2.6.4, 2.7.2, 2.8.1
tensorflow PyPIAll versions2.6.4
tensorflow PyPIAll versions2.6.4
tensorflow PyPIFrom 2.7.02.7.2
tensorflow PyPIFrom 2.7.02.7.2
16 more packages
tensorflow PyPIFrom 2.8.02.8.1
tensorflow PyPIFrom 2.8.02.8.1
tensorflow-cpu PyPIAll versions2.6.4, 2.7.2, 2.8.1
tensorflow-cpu PyPIAll versions2.6.4
tensorflow-cpu PyPIAll versions2.6.4
tensorflow-cpu PyPIFrom 2.7.02.7.2
tensorflow-cpu PyPIFrom 2.7.02.7.2
tensorflow-cpu PyPIFrom 2.8.02.8.1
tensorflow-cpu PyPIFrom 2.8.02.8.1
tensorflow-gpu PyPIAll versions2.6.4, 2.7.2, 2.8.1
tensorflow-gpu PyPIAll versions2.6.4
tensorflow-gpu PyPIAll versions2.6.4
tensorflow-gpu PyPIFrom 2.7.02.7.2
tensorflow-gpu PyPIFrom 2.7.02.7.2
tensorflow-gpu PyPIFrom 2.8.02.8.1
tensorflow-gpu PyPIFrom 2.8.02.8.1

Products include Google Tensorflow.

How do I fix CVE-2022-29204?

Upgrade tensorflow to a fixed version for your release line: 2.6.4, 2.7.2 or 2.8.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2022-29204 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-29204 exists.

All Google Tensorflow vulnerabilities

Sources

Also known as BIT-tensorflow-2022-29204, GHSA-hx9q-2mx4-m4pg, PYSEC-2026-1010, PYSEC-2026-3203, PYSEC-2026-3342.

Is CVE-2022-29204 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free