CVE-2022-29205 Segfault due to missing support for quantized types in TensorFlow
Attackers can cause a denial of service via segfault in TensorFlow by invoking legacy operations with unsupported quantized types.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-29205?
CVE-2022-29205 is a medium-severity vulnerability in Google Tensorflow, published on 20 May 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
TensorFlow is an open source platform for machine learning. Prior to versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4, there is a potential for segfault / denial of service in TensorFlow by calling `tf.compat.v1.*` ops which don't yet have support for quantized types, which was added after migration to TensorFlow 2.x. In these scenarios, since the kernel is missing, a `nullptr` value is passed to `ParseDimensionValue` for the `py_value` argument. Then, this is dereferenced, resulting in segfault. Versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4 contain a patch for this issue.
Which versions are affected by CVE-2022-29205?
22 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
tensorflow Bitnami | All versions | 2.6.4, 2.7.2, 2.8.1 |
tensorflow PyPI | All versions | 2.6.4, 2.7.2, 2.8.1 |
tensorflow PyPI | All versions | 2.6.4 |
tensorflow PyPI | All versions | 2.6.4 |
tensorflow PyPI | From 2.7.0 | 2.7.2 |
tensorflow PyPI | From 2.7.0 | 2.7.2 |
16 more packages
tensorflow PyPI | From 2.8.0 | 2.8.1 |
tensorflow PyPI | From 2.8.0 | 2.8.1 |
tensorflow-cpu PyPI | All versions | 2.6.4, 2.7.2, 2.8.1 |
tensorflow-cpu PyPI | All versions | 2.6.4 |
tensorflow-cpu PyPI | All versions | 2.6.4 |
tensorflow-cpu PyPI | From 2.7.0 | 2.7.2 |
tensorflow-cpu PyPI | From 2.7.0 | 2.7.2 |
tensorflow-cpu PyPI | From 2.8.0 | 2.8.1 |
tensorflow-cpu PyPI | From 2.8.0 | 2.8.1 |
tensorflow-gpu PyPI | All versions | 2.6.4, 2.7.2, 2.8.1 |
tensorflow-gpu PyPI | All versions | 2.6.4 |
tensorflow-gpu PyPI | All versions | 2.6.4 |
tensorflow-gpu PyPI | From 2.7.0 | 2.7.2 |
tensorflow-gpu PyPI | From 2.7.0 | 2.7.2 |
tensorflow-gpu PyPI | From 2.8.0 | 2.8.1 |
tensorflow-gpu PyPI | From 2.8.0 | 2.8.1 |
Products include Google Tensorflow.
How do I fix CVE-2022-29205?
Upgrade tensorflow to a fixed version for your release line: 2.6.4, 2.7.2 or 2.8.1.
Is CVE-2022-29205 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-29205 exists.
Other vulnerabilities in Google Tensorflow
- CVE-2023-25668 TensorFlow vulnerable to heap out-of-buffer read in the QuantizeAndDequantize operation
- CVE-2018-7575 Integer Overflow or Wraparound in Google TensorFlow
- CVE-2021-37678 Arbitrary code execution due to YAML deserialization
- CVE-2021-35958 Path traversal in n/a
- CVE-2020-15202 Integer truncation in Shard API usage
Sources
Also known as BIT-tensorflow-2022-29205, GHSA-54ch-gjq5-4976, PYSEC-2026-3104, PYSEC-2026-3274, PYSEC-2026-950.