CVE-2022-29206 Missing validation results in undefined behavior in `SparseTensorDenseAdd` in TensorFlow

Medium 5.5 Published Updated

An attacker can cause a null pointer dereference and undefined behavior in TensorFlow's SparseTensorDenseAdd operation by providing invalid input arguments.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2022-29206?

CVE-2022-29206 is a medium-severity vulnerability in Google Tensorflow, published on 20 May 2022. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

TensorFlow is an open source platform for machine learning. Prior to versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4, the implementation of `tf.raw_ops.SparseTensorDenseAdd` does not fully validate the input arguments. In this case, a reference gets bound to a `nullptr` during kernel execution. This is undefined behavior. Versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4 contain a patch for this issue.

Weakness: CWE-476, CWE-20

Which versions are affected by CVE-2022-29206?

22 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 1 product.

PackageAffectedFixed in
tensorflow BitnamiAll versions2.6.4, 2.7.2, 2.8.1
tensorflow PyPIAll versions2.6.4, 2.7.2, 2.8.1
tensorflow PyPIAll versions2.6.4
tensorflow PyPIAll versions2.6.4
tensorflow PyPIFrom 2.7.02.7.2
tensorflow PyPIFrom 2.7.02.7.2
16 more packages
tensorflow PyPIFrom 2.8.02.8.1
tensorflow PyPIFrom 2.8.02.8.1
tensorflow-cpu PyPIAll versions2.6.4, 2.7.2, 2.8.1
tensorflow-cpu PyPIAll versions2.6.4
tensorflow-cpu PyPIAll versions2.6.4
tensorflow-cpu PyPIFrom 2.7.02.7.2
tensorflow-cpu PyPIFrom 2.7.02.7.2
tensorflow-cpu PyPIFrom 2.8.02.8.1
tensorflow-cpu PyPIFrom 2.8.02.8.1
tensorflow-gpu PyPIAll versions2.6.4, 2.7.2, 2.8.1
tensorflow-gpu PyPIAll versions2.6.4
tensorflow-gpu PyPIAll versions2.6.4
tensorflow-gpu PyPIFrom 2.7.02.7.2
tensorflow-gpu PyPIFrom 2.7.02.7.2
tensorflow-gpu PyPIFrom 2.8.02.8.1
tensorflow-gpu PyPIFrom 2.8.02.8.1

Products include Google Tensorflow.

How do I fix CVE-2022-29206?

Upgrade tensorflow to a fixed version for your release line: 2.6.4, 2.7.2 or 2.8.1.

Is CVE-2022-29206 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-29206 exists.

All Google Tensorflow vulnerabilities

Sources

Also known as BIT-tensorflow-2022-29206, GHSA-rc9w-5c64-9vqq, PYSEC-2026-1032, PYSEC-2026-3235, PYSEC-2026-3365.

Is CVE-2022-29206 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free