CVE-2022-29207 Undefined behavior when users supply invalid resource handles in TensorFlow

Medium 5.5 Published Updated

Attackers can cause undefined behavior and potential crashes in TensorFlow by supplying invalid resource handles in eager mode.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2022-29207?

CVE-2022-29207 is a medium-severity vulnerability in Google Tensorflow, published on 20 May 2022. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

TensorFlow is an open source platform for machine learning. Prior to versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4, multiple TensorFlow operations misbehave in eager mode when the resource handle provided to them is invalid. In graph mode, it would have been impossible to perform these API calls, but migration to TF 2.x eager mode opened up this vulnerability. If the resource handle is empty, then a reference is bound to a null pointer inside TensorFlow codebase (various codepaths). This is undefined behavior. Versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4 contain a patch for this issue.

Weakness: CWE-475, CWE-20

Which versions are affected by CVE-2022-29207?

22 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 1 product.

PackageAffectedFixed in
tensorflow BitnamiAll versions2.6.4, 2.7.2, 2.8.1
tensorflow PyPIAll versions2.6.4, 2.7.2, 2.8.1
tensorflow PyPIAll versions2.6.4
tensorflow PyPIAll versions2.6.4
tensorflow PyPIFrom 2.7.02.7.2
tensorflow PyPIFrom 2.7.02.7.2
16 more packages
tensorflow PyPIFrom 2.8.02.8.1
tensorflow PyPIFrom 2.8.02.8.1
tensorflow-cpu PyPIAll versions2.6.4, 2.7.2, 2.8.1
tensorflow-cpu PyPIAll versions2.6.4
tensorflow-cpu PyPIAll versions2.6.4
tensorflow-cpu PyPIFrom 2.7.02.7.2
tensorflow-cpu PyPIFrom 2.7.02.7.2
tensorflow-cpu PyPIFrom 2.8.02.8.1
tensorflow-cpu PyPIFrom 2.8.02.8.1
tensorflow-gpu PyPIAll versions2.6.4, 2.7.2, 2.8.1
tensorflow-gpu PyPIAll versions2.6.4
tensorflow-gpu PyPIAll versions2.6.4
tensorflow-gpu PyPIFrom 2.7.02.7.2
tensorflow-gpu PyPIFrom 2.7.02.7.2
tensorflow-gpu PyPIFrom 2.8.02.8.1
tensorflow-gpu PyPIFrom 2.8.02.8.1

Products include Google Tensorflow.

How do I fix CVE-2022-29207?

Upgrade tensorflow to a fixed version for your release line: 2.6.4, 2.7.2 or 2.8.1.

Is CVE-2022-29207 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-29207 exists.

All Google Tensorflow vulnerabilities

Sources

Also known as BIT-tensorflow-2022-29207, GHSA-5wpj-c6f7-24x8, PYSEC-2026-3112, PYSEC-2026-3280, PYSEC-2026-955.

Is CVE-2022-29207 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free