CVE-2022-29209 Type confusion leading to `CHECK`-failure based denial of service in TensorFlow
Attackers can cause a denial of service in TensorFlow applications by triggering incorrect assertion checks due to type confusion errors.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-29209?
CVE-2022-29209 is a medium-severity denial of service vulnerability in Google Tensorflow, published on 20 May 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
TensorFlow is an open source platform for machine learning. Prior to versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4, the macros that TensorFlow uses for writing assertions (e.g., `CHECK_LT`, `CHECK_GT`, etc.) have an incorrect logic when comparing `size_t` and `int` values. Due to type conversion rules, several of the macros would trigger incorrectly. Versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4 contain a patch for this issue.
Weakness: CWE-843
Which versions are affected by CVE-2022-29209?
22 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
tensorflow Bitnami | All versions | 2.6.4, 2.7.2, 2.8.1 |
tensorflow PyPI | All versions | 2.6.4, 2.7.2, 2.8.1 |
tensorflow PyPI | All versions | 2.6.4 |
tensorflow PyPI | All versions | 2.6.4 |
tensorflow PyPI | From 2.7.0 | 2.7.2 |
tensorflow PyPI | From 2.7.0 | 2.7.2 |
16 more packages
tensorflow PyPI | From 2.8.0 | 2.8.1 |
tensorflow PyPI | From 2.8.0 | 2.8.1 |
tensorflow-cpu PyPI | All versions | 2.6.4, 2.7.2, 2.8.1 |
tensorflow-cpu PyPI | All versions | 2.6.4 |
tensorflow-cpu PyPI | All versions | 2.6.4 |
tensorflow-cpu PyPI | From 2.7.0 | 2.7.2 |
tensorflow-cpu PyPI | From 2.7.0 | 2.7.2 |
tensorflow-cpu PyPI | From 2.8.0 | 2.8.1 |
tensorflow-cpu PyPI | From 2.8.0 | 2.8.1 |
tensorflow-gpu PyPI | All versions | 2.6.4, 2.7.2, 2.8.1 |
tensorflow-gpu PyPI | All versions | 2.6.4 |
tensorflow-gpu PyPI | All versions | 2.6.4 |
tensorflow-gpu PyPI | From 2.7.0 | 2.7.2 |
tensorflow-gpu PyPI | From 2.7.0 | 2.7.2 |
tensorflow-gpu PyPI | From 2.8.0 | 2.8.1 |
tensorflow-gpu PyPI | From 2.8.0 | 2.8.1 |
Products include Google Tensorflow.
How do I fix CVE-2022-29209?
Upgrade tensorflow to a fixed version for your release line: 2.6.4, 2.7.2 or 2.8.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2022-29209 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-29209 exists.
Other vulnerabilities in Google Tensorflow
- CVE-2023-25668 TensorFlow vulnerable to heap out-of-buffer read in the QuantizeAndDequantize operation
- CVE-2018-7575 Integer Overflow or Wraparound in Google TensorFlow
- CVE-2021-37678 Arbitrary code execution due to YAML deserialization
- CVE-2021-35958 Path traversal in n/a
- CVE-2020-15202 Integer truncation in Shard API usage
Sources
Also known as BIT-tensorflow-2022-29209, GHSA-f4rr-5m7v-wxcw, PYSEC-2026-3167, PYSEC-2026-3315, PYSEC-2026-986.