# CVE-2022-29209: Type confusion leading to `CHECK`-failure based denial of service in TensorFlow

> Attackers can cause a denial of service in TensorFlow applications by triggering incorrect assertion checks due to type confusion errors.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 May 2022
- **Updated:** 22 Apr 2025
- **Also known as:** BIT-tensorflow-2022-29209, GHSA-f4rr-5m7v-wxcw, PYSEC-2026-3167, PYSEC-2026-3315, PYSEC-2026-986

## What is CVE-2022-29209?

CVE-2022-29209 is a medium-severity denial of service vulnerability in Google Tensorflow, published on 20 May 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

TensorFlow is an open source platform for machine learning. Prior to versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4, the macros that TensorFlow uses for writing assertions (e.g., `CHECK_LT`, `CHECK_GT`, etc.) have an incorrect logic when comparing `size_t` and `int` values. Due to type conversion rules, several of the macros would trigger incorrectly. Versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4 contain a patch for this issue.

Weakness: CWE-843 (Access of Resource Using Incompatible Type)

## Which versions are affected by CVE-2022-29209?

22 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tensorflow` | Bitnami | All versions | 2.6.4, 2.7.2, 2.8.1 |
| `tensorflow` | PyPI | All versions | 2.6.4, 2.7.2, 2.8.1 |
| `tensorflow` | PyPI | All versions | 2.6.4 |
| `tensorflow` | PyPI | All versions | 2.6.4 |
| `tensorflow` | PyPI | From 2.7.0 | 2.7.2 |
| `tensorflow` | PyPI | From 2.7.0 | 2.7.2 |
| `tensorflow` | PyPI | From 2.8.0 | 2.8.1 |
| `tensorflow` | PyPI | From 2.8.0 | 2.8.1 |
| `tensorflow-cpu` | PyPI | All versions | 2.6.4, 2.7.2, 2.8.1 |
| `tensorflow-cpu` | PyPI | All versions | 2.6.4 |
| `tensorflow-cpu` | PyPI | All versions | 2.6.4 |
| `tensorflow-cpu` | PyPI | From 2.7.0 | 2.7.2 |
| `tensorflow-cpu` | PyPI | From 2.7.0 | 2.7.2 |
| `tensorflow-cpu` | PyPI | From 2.8.0 | 2.8.1 |
| `tensorflow-cpu` | PyPI | From 2.8.0 | 2.8.1 |
| `tensorflow-gpu` | PyPI | All versions | 2.6.4, 2.7.2, 2.8.1 |
| `tensorflow-gpu` | PyPI | All versions | 2.6.4 |
| `tensorflow-gpu` | PyPI | All versions | 2.6.4 |
| `tensorflow-gpu` | PyPI | From 2.7.0 | 2.7.2 |
| `tensorflow-gpu` | PyPI | From 2.7.0 | 2.7.2 |
| `tensorflow-gpu` | PyPI | From 2.8.0 | 2.8.1 |
| `tensorflow-gpu` | PyPI | From 2.8.0 | 2.8.1 |

Products: Google Tensorflow.

## How do I fix CVE-2022-29209?

Upgrade tensorflow to a fixed version for your release line: 2.6.4, 2.7.2 or 2.8.1.

## Is CVE-2022-29209 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-29209 exists.

## Other vulnerabilities in Google Tensorflow

- [CVE-2023-25668](https://insights.sbomify.com/CVE-2023-25668/): TensorFlow vulnerable to heap out-of-buffer read in the QuantizeAndDequantize operation (critical 9.8)
- [CVE-2018-7575](https://insights.sbomify.com/CVE-2018-7575/): Integer Overflow or Wraparound in Google TensorFlow (critical 9.8)
- [CVE-2021-37678](https://insights.sbomify.com/CVE-2021-37678/): Arbitrary code execution due to YAML deserialization (critical 9.3)
- [CVE-2021-35958](https://insights.sbomify.com/CVE-2021-35958/): Path traversal in n/a (critical 9.1)
- [CVE-2020-15202](https://insights.sbomify.com/CVE-2020-15202/): Integer truncation in Shard API usage (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-29209 and fix it if it is affected.

What it is: CVE-2022-29209 is a medium-severity denial of service vulnerability in Google Tensorflow, published on 20 May 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-29209 exists.

Affected packages and fixed versions:
- tensorflow (Bitnami): affected all versions; fixed in 2.6.4, 2.7.2, 2.8.1
- tensorflow (PyPI): affected all versions; fixed in 2.6.4, 2.7.2, 2.8.1
- tensorflow (PyPI): affected all versions; fixed in 2.6.4
- tensorflow (PyPI): affected all versions; fixed in 2.6.4
- tensorflow (PyPI): affected from 2.7.0; fixed in 2.7.2
- tensorflow (PyPI): affected from 2.7.0; fixed in 2.7.2
- tensorflow (PyPI): affected from 2.8.0; fixed in 2.8.1
- tensorflow (PyPI): affected from 2.8.0; fixed in 2.8.1
- tensorflow-cpu (PyPI): affected all versions; fixed in 2.6.4, 2.7.2, 2.8.1
- tensorflow-cpu (PyPI): affected all versions; fixed in 2.6.4
- tensorflow-cpu (PyPI): affected all versions; fixed in 2.6.4
- tensorflow-cpu (PyPI): affected from 2.7.0; fixed in 2.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-29209/ (Markdown: https://insights.sbomify.com/CVE-2022-29209/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-29209
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-29209
- OSV: https://osv.dev/vulnerability/CVE-2022-29209

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-29209/
Summaries are generated and may contain mistakes; the official description above is the record.
