CVE-2022-29211 Segfault in TensorFlow if `tf.histogram_fixed_width` is called with NaN values

Medium 5.5 Published Updated

An attacker can cause a denial of service by passing NaN values to tf.histogram_fixed_width, crashing the application.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2022-29211?

CVE-2022-29211 is a medium-severity denial of service vulnerability in Google Tensorflow, published on 20 May 2022. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

TensorFlow is an open source platform for machine learning. Prior to versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4, the implementation of `tf.histogram_fixed_width` is vulnerable to a crash when the values array contain `Not a Number` (`NaN`) elements. The implementation assumes that all floating point operations are defined and then converts a floating point result to an integer index. If `values` contains `NaN` then the result of the division is still `NaN` and the cast to `int32` would result in a crash. This only occurs on the CPU implementation. Versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4 contain a patch for this issue.

Weakness: CWE-20

Which versions are affected by CVE-2022-29211?

22 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 1 product.

PackageAffectedFixed in
tensorflow BitnamiAll versions2.6.4, 2.7.2, 2.8.1
tensorflow PyPIAll versions2.6.4, 2.7.2, 2.8.1
tensorflow PyPIAll versions2.6.4
tensorflow PyPIAll versions2.6.4
tensorflow PyPIFrom 2.7.02.7.2
tensorflow PyPIFrom 2.7.02.7.2
16 more packages
tensorflow PyPIFrom 2.8.02.8.1
tensorflow PyPIFrom 2.8.02.8.1
tensorflow-cpu PyPIAll versions2.6.4, 2.7.2, 2.8.1
tensorflow-cpu PyPIAll versions2.6.4
tensorflow-cpu PyPIAll versions2.6.4
tensorflow-cpu PyPIFrom 2.7.02.7.2
tensorflow-cpu PyPIFrom 2.7.02.7.2
tensorflow-cpu PyPIFrom 2.8.02.8.1
tensorflow-cpu PyPIFrom 2.8.02.8.1
tensorflow-gpu PyPIAll versions2.6.4, 2.7.2, 2.8.1
tensorflow-gpu PyPIAll versions2.6.4
tensorflow-gpu PyPIAll versions2.6.4
tensorflow-gpu PyPIFrom 2.7.02.7.2
tensorflow-gpu PyPIFrom 2.7.02.7.2
tensorflow-gpu PyPIFrom 2.8.02.8.1
tensorflow-gpu PyPIFrom 2.8.02.8.1

Products include Google Tensorflow.

How do I fix CVE-2022-29211?

Upgrade tensorflow to a fixed version for your release line: 2.6.4, 2.7.2 or 2.8.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2022-29211 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-29211 exists.

All Google Tensorflow vulnerabilities

Sources

Also known as BIT-tensorflow-2022-29211, GHSA-xrp2-fhq4-4q3w, PYSEC-2026-1048, PYSEC-2026-3260, PYSEC-2026-3382.

Is CVE-2022-29211 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free