{"answers":{"affected":"4 open source packages ship an affected version, including next-auth. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-29214 in the wild and no public exploit code.","fix":"Upgrade next-auth to a fixed version for your release line: 3.29.3 or 4.3.3.","what":"CVE-2022-29214 is a medium-severity vulnerability in nextauthjs next-auth, published on 20 May 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-29214 and fix it if it is affected.\n\nWhat it is: CVE-2022-29214 is a medium-severity vulnerability in nextauthjs next-auth, published on 20 May 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-29214 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- next-auth (npm): affected all versions; fixed in 3.29.3\n- next-auth (npm): affected all versions; fixed in 3.29.3\n- next-auth (npm): affected from 4.0.0; fixed in 4.3.3\n- next-auth (npm): affected from 4.0.0; fixed in 4.3.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-29214/ (Markdown: https://insights.sbomify.com/CVE-2022-29214/index.md)","id":"CVE-2022-29214","markdown":"https://insights.sbomify.com/CVE-2022-29214/index.md","name":"CVE-2022-29214","record":{"aliases":["GHSA-q2mx-j4x2-2h74"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Next.js authentication library","requires_auth":"none","summary":"An open redirect vulnerability in next-auth allows attackers to redirect users to untrusted sites when using OAuth 1 providers.","user_interaction":"required","vuln_class":"open_redirect"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"next-auth","vendor":"nextauth.js"}],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-601","name":"URL Redirection to Untrusted Site"}],"description":"NextAuth.js (next-auth) is am open source authentication solution for Next.js applications. Prior to versions 3.29.3 and 4.3.3, an open redirect vulnerability is present when the developer is implementing an OAuth 1 provider. Versions 3.29.3 and 4.3.3 contain a patch for this issue. The maintainers recommend adding a certain configuration to one's `callbacks` option as a workaround for those unable to upgrade.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"URL Redirection to Untrusted Site ('Open Redirect') in next-auth","id":"CVE-2022-29214","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"open_redirect","year":"2022"},"n_packages":4,"n_references":2,"next":{"headline":"Argument Injection in RegionProtect","id":"CVE-2022-29215"},"packages":[{"ecosystem":"npm","fixed":["3.29.3"],"introduced":["0"],"last_affected":[],"package":"next-auth","purl":null,"source":"GHSA-q2mx-j4x2-2h74"},{"ecosystem":"npm","fixed":["3.29.3"],"introduced":["0"],"last_affected":[],"package":"next-auth","purl":"pkg:npm/next-auth","source":"GHSA-q2mx-j4x2-2h74"},{"ecosystem":"npm","fixed":["4.3.3"],"introduced":["4.0.0"],"last_affected":[],"package":"next-auth","purl":null,"source":"GHSA-q2mx-j4x2-2h74"},{"ecosystem":"npm","fixed":["4.3.3"],"introduced":["4.0.0"],"last_affected":[],"package":"next-auth","purl":"pkg:npm/next-auth","source":"GHSA-q2mx-j4x2-2h74"}],"prev":{"headline":"Incomplete validation in signal ops leads to crashes in TensorFlow","id":"CVE-2022-29213"},"products":["next-auth"],"published":"2022-05-20","related":[{"cvss_score":9.1,"headline":"Verification requests (magic link) sent to unwanted emails","id":"CVE-2022-35924","kev_date_added":null,"published":"2022-08-02"},{"cvss_score":8.1,"headline":"Missing proper state, nonce and PKCE checks for OAuth authentication in next-auth","id":"CVE-2023-27490","kev_date_added":null,"published":"2023-03-09"},{"cvss_score":7.5,"headline":"Improper Handling of `callbackUrl` parameter in next-auth","id":"CVE-2022-31093","kev_date_added":null,"published":"2022-06-27"},{"cvss_score":7.1,"headline":"Improper handling of email input in next-auth","id":"CVE-2022-31127","kev_date_added":null,"published":"2022-07-06"},{"cvss_score":6.8,"headline":"NextAuth.js Upstash Adapter missing token verification","id":"CVE-2022-39263","kev_date_added":null,"published":"2022-09-28"},{"cvss_score":6.1,"headline":"Default redirect callback vulnerable to open redirects","id":"CVE-2022-24858","kev_date_added":null,"published":"2022-04-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["nextauthjs"]},"summary":"An open redirect vulnerability in next-auth allows attackers to redirect users to untrusted sites when using OAuth 1 providers.","url":"https://insights.sbomify.com/CVE-2022-29214/"}