# CVE-2022-29214: URL Redirection to Untrusted Site ('Open Redirect') in next-auth

> An open redirect vulnerability in next-auth allows attackers to redirect users to untrusted sites when using OAuth 1 providers.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 May 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-q2mx-j4x2-2h74

## What is CVE-2022-29214?

CVE-2022-29214 is a medium-severity vulnerability in nextauthjs next-auth, published on 20 May 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

NextAuth.js (next-auth) is am open source authentication solution for Next.js applications. Prior to versions 3.29.3 and 4.3.3, an open redirect vulnerability is present when the developer is implementing an OAuth 1 provider. Versions 3.29.3 and 4.3.3 contain a patch for this issue. The maintainers recommend adding a certain configuration to one's `callbacks` option as a workaround for those unable to upgrade.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2022-29214?

4 open source packages ship an affected version, including next-auth. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `next-auth` | npm | All versions | 3.29.3 |
| `next-auth` | npm | All versions | 3.29.3 |
| `next-auth` | npm | From 4.0.0 | 4.3.3 |
| `next-auth` | npm | From 4.0.0 | 4.3.3 |

Products: Nextauth.js Next-Auth.

## How do I fix CVE-2022-29214?

Upgrade next-auth to a fixed version for your release line: 3.29.3 or 4.3.3.

## Is CVE-2022-29214 being exploited?

There is no known exploitation of CVE-2022-29214 in the wild and no public exploit code.

## Other vulnerabilities in nextauthjs next-auth

- [CVE-2022-35924](https://insights.sbomify.com/CVE-2022-35924/): Verification requests (magic link) sent to unwanted emails (critical 9.1)
- [CVE-2023-27490](https://insights.sbomify.com/CVE-2023-27490/): Missing proper state, nonce and PKCE checks for OAuth authentication in next-auth (high 8.1)
- [CVE-2022-31093](https://insights.sbomify.com/CVE-2022-31093/): Improper Handling of `callbackUrl` parameter in next-auth (high 7.5)
- [CVE-2022-31127](https://insights.sbomify.com/CVE-2022-31127/): Improper handling of email input in next-auth (high 7.1)
- [CVE-2022-39263](https://insights.sbomify.com/CVE-2022-39263/): NextAuth.js Upstash Adapter missing token verification (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-29214 and fix it if it is affected.

What it is: CVE-2022-29214 is a medium-severity vulnerability in nextauthjs next-auth, published on 20 May 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-29214 in the wild and no public exploit code.

Affected packages and fixed versions:
- next-auth (npm): affected all versions; fixed in 3.29.3
- next-auth (npm): affected all versions; fixed in 3.29.3
- next-auth (npm): affected from 4.0.0; fixed in 4.3.3
- next-auth (npm): affected from 4.0.0; fixed in 4.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-29214/ (Markdown: https://insights.sbomify.com/CVE-2022-29214/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-29214
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-29214
- OSV: https://osv.dev/vulnerability/CVE-2022-29214

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-29214/
Summaries are generated and may contain mistakes; the official description above is the record.
