CVE-2022-29216 Code injection in `saved_model_cli` in TensorFlow
Attackers can execute arbitrary code via reverse shell through code injection in the saved_model_cli tool, requiring an upgrade to patched TensorFlow versions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-29216?
CVE-2022-29216 is a high-severity code injection vulnerability in Google Tensorflow, published on 20 May 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
TensorFlow is an open source platform for machine learning. Prior to versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4, TensorFlow's `saved_model_cli` tool is vulnerable to a code injection. This can be used to open a reverse shell. This code path was maintained for compatibility reasons as the maintainers had several test cases where numpy expressions were used as arguments. However, given that the tool is always run manually, the impact of this is still not severe. The maintainers have now removed the `safe=False` argument, so all parsing is done without calling `eval`. The patch is available in versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4.
Weakness: CWE-94
Which versions are affected by CVE-2022-29216?
22 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
tensorflow Bitnami | All versions | 2.6.4, 2.7.2, 2.8.1 |
tensorflow PyPI | All versions | 2.6.4, 2.7.2, 2.8.1 |
tensorflow PyPI | All versions | 2.6.4 |
tensorflow PyPI | All versions | 2.6.4 |
tensorflow PyPI | From 2.7.0 | 2.7.2 |
tensorflow PyPI | From 2.7.0 | 2.7.2 |
16 more packages
tensorflow PyPI | From 2.8.0 | 2.8.1 |
tensorflow PyPI | From 2.8.0 | 2.8.1 |
tensorflow-cpu PyPI | All versions | 2.6.4, 2.7.2, 2.8.1 |
tensorflow-cpu PyPI | All versions | 2.6.4 |
tensorflow-cpu PyPI | All versions | 2.6.4 |
tensorflow-cpu PyPI | From 2.7.0 | 2.7.2 |
tensorflow-cpu PyPI | From 2.7.0 | 2.7.2 |
tensorflow-cpu PyPI | From 2.8.0 | 2.8.1 |
tensorflow-cpu PyPI | From 2.8.0 | 2.8.1 |
tensorflow-gpu PyPI | All versions | 2.6.4, 2.7.2, 2.8.1 |
tensorflow-gpu PyPI | All versions | 2.6.4 |
tensorflow-gpu PyPI | All versions | 2.6.4 |
tensorflow-gpu PyPI | From 2.7.0 | 2.7.2 |
tensorflow-gpu PyPI | From 2.7.0 | 2.7.2 |
tensorflow-gpu PyPI | From 2.8.0 | 2.8.1 |
tensorflow-gpu PyPI | From 2.8.0 | 2.8.1 |
Products include Google Tensorflow.
How do I fix CVE-2022-29216?
Upgrade tensorflow to a fixed version for your release line: 2.6.4, 2.7.2 or 2.8.1.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2022-29216 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-29216 exists.
Other vulnerabilities in Google Tensorflow
- CVE-2023-25668 TensorFlow vulnerable to heap out-of-buffer read in the QuantizeAndDequantize operation
- CVE-2018-7575 Integer Overflow or Wraparound in Google TensorFlow
- CVE-2021-37678 Arbitrary code execution due to YAML deserialization
- CVE-2021-35958 Path traversal in n/a
- CVE-2020-15202 Integer truncation in Shard API usage
Sources
Also known as BIT-tensorflow-2022-29216, GHSA-75c9-jrh4-79mc, PYSEC-2026-3125, PYSEC-2026-3289, PYSEC-2026-963.