{"answers":{"affected":"2 open source packages ship an affected version, including @chainsafe/lodestar. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-29219 in the wild and no public exploit code.","fix":"Upgrade @chainsafe/lodestar to 0.36.0 or later.","what":"CVE-2022-29219 is a high-severity vulnerability in ChainSafe lodestar, published on 24 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-29219 and fix it if it is affected.\n\nWhat it is: CVE-2022-29219 is a high-severity vulnerability in ChainSafe lodestar, published on 24 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-29219 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @chainsafe/lodestar (npm): affected all versions; fixed in 0.36.0\n- @chainsafe/lodestar (npm): affected all versions; fixed in 0.36.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-29219/ (Markdown: https://insights.sbomify.com/CVE-2022-29219/index.md)","id":"CVE-2022-29219","markdown":"https://insights.sbomify.com/CVE-2022-29219/index.md","name":"CVE-2022-29219","record":{"aliases":["GHSA-cvj7-5f3c-9vg9"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service","other"],"network_reachable":"yes","non_default_config":false,"product_category":"Ethereum consensus client","requires_auth":"none","summary":"Malicious slashing events cause consensus splits in Lodestar nodes due to integer overflow, leading to network forks or invalid block proposals.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"lodestar","vendor":"chainsafe"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-190","name":"Integer Overflow or Wraparound"}],"description":"Lodestar is a TypeScript implementation of the Ethereum Consensus specification. Prior to version 0.36.0, there is a possible consensus split given maliciously-crafted `AttesterSlashing` or `ProposerSlashing` being included on-chain. Because the developers represent `uint64` values as native javascript `number`s, there is an issue when those variables with large (greater than 2^53) `uint64` values are included on chain. In those cases, Lodestar may view valid_`AttesterSlashing` or `ProposerSlashing` as invalid, due to rounding errors in large `number` values. This causes a consensus split, where Lodestar nodes are forked away from the main network. Similarly, Lodestar may consider invalid `ProposerSlashing` as valid, thus including in proposed blocks that will be considered invalid by the network. Version 0.36.0 contains a fix for this issue. As a workaround, use `BigInt` to represent `Slot` and `Epoch` values in `AttesterSlashing` and `ProposerSlashing` objects. `BigInt` is too slow to be used in all `Slot` and `Epoch` cases, so one may carefully use `BigInt` just where necessary for consensus.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Integer Overflow in Lodestar","id":"CVE-2022-29219","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"integer_overflow","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"No verification of commits origin in github-action-merge-dependabot","id":"CVE-2022-29220"},"packages":[{"ecosystem":"npm","fixed":["0.36.0"],"introduced":["0"],"last_affected":[],"package":"@chainsafe/lodestar","purl":null,"source":"GHSA-cvj7-5f3c-9vg9"},{"ecosystem":"npm","fixed":["0.36.0"],"introduced":["0"],"last_affected":[],"package":"@chainsafe/lodestar","purl":"pkg:npm/%40chainsafe/lodestar","source":"GHSA-cvj7-5f3c-9vg9"}],"prev":{"headline":"Unauthorized takeover for new versions of some platform-specific gems","id":"CVE-2022-29218"},"products":["lodestar"],"published":"2022-05-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["ChainSafe"]},"summary":"Malicious slashing events cause consensus splits in Lodestar nodes due to integer overflow, leading to network forks or invalid block proposals.","url":"https://insights.sbomify.com/CVE-2022-29219/"}