# CVE-2022-29219: Integer Overflow in Lodestar

> Malicious slashing events cause consensus splits in Lodestar nodes due to integer overflow, leading to network forks or invalid block proposals.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 May 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-cvj7-5f3c-9vg9

## What is CVE-2022-29219?

CVE-2022-29219 is a high-severity vulnerability in ChainSafe lodestar, published on 24 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Lodestar is a TypeScript implementation of the Ethereum Consensus specification. Prior to version 0.36.0, there is a possible consensus split given maliciously-crafted `AttesterSlashing` or `ProposerSlashing` being included on-chain. Because the developers represent `uint64` values as native javascript `number`s, there is an issue when those variables with large (greater than 2^53) `uint64` values are included on chain. In those cases, Lodestar may view valid_`AttesterSlashing` or `ProposerSlashing` as invalid, due to rounding errors in large `number` values. This causes a consensus split, where Lodestar nodes are forked away from the main network. Similarly, Lodestar may consider invalid `ProposerSlashing` as valid, thus including in proposed blocks that will be considered invalid by the network. Version 0.36.0 contains a fix for this issue. As a workaround, use `BigInt` to represent `Slot` and `Epoch` values in `AttesterSlashing` and `ProposerSlashing` objects. `BigInt` is too slow to be used in all `Slot` and `Epoch` cases, so one may carefully use `BigInt` just where necessary for consensus.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2022-29219?

2 open source packages ship an affected version, including @chainsafe/lodestar. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@chainsafe/lodestar` | npm | All versions | 0.36.0 |
| `@chainsafe/lodestar` | npm | All versions | 0.36.0 |

Products: Chainsafe Lodestar.

## How do I fix CVE-2022-29219?

Upgrade @chainsafe/lodestar to 0.36.0 or later.

## Is CVE-2022-29219 being exploited?

There is no known exploitation of CVE-2022-29219 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-29219 and fix it if it is affected.

What it is: CVE-2022-29219 is a high-severity vulnerability in ChainSafe lodestar, published on 24 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-29219 in the wild and no public exploit code.

Affected packages and fixed versions:
- @chainsafe/lodestar (npm): affected all versions; fixed in 0.36.0
- @chainsafe/lodestar (npm): affected all versions; fixed in 0.36.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-29219/ (Markdown: https://insights.sbomify.com/CVE-2022-29219/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-29219
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-29219
- OSV: https://osv.dev/vulnerability/CVE-2022-29219

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-29219/
Summaries are generated and may contain mistakes; the official description above is the record.
