# CVE-2022-2922: Relative Path Traversal in dnnsoftware/dnn.platform

> Attackers can exploit relative path traversal in DNN Platform to read or modify arbitrary files on the server.

- **Severity:** Medium 4.9 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Sep 2022
- **Updated:** 20 May 2025
- **Also known as:** GHSA-9w72-2f23-57gm

## What is CVE-2022-2922?

CVE-2022-2922 is a medium-severity path traversal vulnerability in Dnnsoftware Dotnetnuke, published on 30 Sep 2022. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Relative Path Traversal in GitHub repository dnnsoftware/dnn.platform prior to 9.11.0.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-23 (Relative Path Traversal)

## Which versions are affected by CVE-2022-2922?

4 open source packages ship an affected version, including DotNetNuke.Core and DotNetNuke.Web. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `DotNetNuke.Core` | NuGet | All versions | 9.11.0 |
| `DotNetNuke.Core` | NuGet | All versions | 9.11.0 |
| `DotNetNuke.Web` | NuGet | All versions | 9.11.0 |
| `DotNetNuke.Web` | NuGet | All versions | 9.11.0 |

Products: Dnnsoftware Dotnetnuke.

## How do I fix CVE-2022-2922?

Upgrade DotNetNuke.Core to 9.11.0 or later.

## Is CVE-2022-2922 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-2922 exists.

## Other vulnerabilities in Dnnsoftware Dotnetnuke

- [CVE-2017-9822](https://insights.sbomify.com/CVE-2017-9822/): DotNetNuke (DNN) Remote Code Execution (high 8.8, exploited in the wild)
- [CVE-2018-15811](https://insights.sbomify.com/CVE-2018-15811/): DotNetNuke (DNN) Inadequate Encryption Strength (high 7.5, exploited in the wild)
- [CVE-2018-18325](https://insights.sbomify.com/CVE-2018-18325/): DotNetNuke (DNN) Inadequate Encryption Strength (high 7.5, exploited in the wild)
- [CVE-2025-64095](https://insights.sbomify.com/CVE-2025-64095/): DNN Insufficient Access Control - Image Upload allows for Site Content Overwrite (critical 10.0)
- [CVE-2006-3601](https://insights.sbomify.com/CVE-2006-3601/): Privilege escalation in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-2922 and fix it if it is affected.

What it is: CVE-2022-2922 is a medium-severity path traversal vulnerability in Dnnsoftware Dotnetnuke, published on 30 Sep 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-2922 exists.

Affected packages and fixed versions:
- DotNetNuke.Core (NuGet): affected all versions; fixed in 9.11.0
- DotNetNuke.Core (NuGet): affected all versions; fixed in 9.11.0
- DotNetNuke.Web (NuGet): affected all versions; fixed in 9.11.0
- DotNetNuke.Web (NuGet): affected all versions; fixed in 9.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-2922/ (Markdown: https://insights.sbomify.com/CVE-2022-2922/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-2922
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-2922
- OSV: https://osv.dev/vulnerability/CVE-2022-2922

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-2922/
Summaries are generated and may contain mistakes; the official description above is the record.
