# CVE-2022-29221: PHP Code Injection by malicious block or filename in Smarty

> Malicious template authors can inject PHP code via block or include names in Smarty, leading to remote code execution.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 May 2022
- **Updated:** 23 Apr 2025
- **Also known as:** DEBIAN-CVE-2022-29221, DLA-3033-1, GHSA-634x-pc3q-cf4c, MGASA-2022-0226, UBUNTU-CVE-2022-29221, USN-6012-1

## What is CVE-2022-29221?

CVE-2022-29221 is a high-severity code injection vulnerability in Debian Debian Linux, published on 24 May 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Smarty is a template engine for PHP, facilitating the separation of presentation (HTML/CSS) from application logic. Prior to versions 3.1.45 and 4.1.1, template authors could inject php code by choosing a malicious {block} name or {include} file name. Sites that cannot fully trust template authors should upgrade to versions 3.1.45 or 4.1.1 to receive a patch for this issue. There are currently no known workarounds.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2022-29221?

4 open source packages ship an affected version, including smarty/smarty. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `smarty/smarty` | Packagist | All versions | 3.1.45 |
| `smarty/smarty` | Packagist | All versions | 3.1.45 |
| `smarty/smarty` | Packagist | From 4.0.0 | 4.1.1 |
| `smarty/smarty` | Packagist | From 4.0.0 | 4.1.1 |

Products: Debian Debian Linux, Fedoraproject Fedora, Smarty Smarty.

## How do I fix CVE-2022-29221?

Upgrade smarty/smarty to a fixed version for your release line: 3.1.45 or 4.1.1.

## Is CVE-2022-29221 being exploited?

There is no known exploitation of CVE-2022-29221 in the wild and no public exploit code.

Public exploit code:

- CVE-2022-29221 Proof of Concept Code - Smarty RCE (github_poc): https://github.com/sbani/CVE-2022-29221-PoC

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-29221 and fix it if it is affected.

What it is: CVE-2022-29221 is a high-severity code injection vulnerability in Debian Debian Linux, published on 24 May 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-29221 in the wild and no public exploit code.

Affected packages and fixed versions:
- smarty/smarty (Packagist): affected all versions; fixed in 3.1.45
- smarty/smarty (Packagist): affected all versions; fixed in 3.1.45
- smarty/smarty (Packagist): affected from 4.0.0; fixed in 4.1.1
- smarty/smarty (Packagist): affected from 4.0.0; fixed in 4.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-29221/ (Markdown: https://insights.sbomify.com/CVE-2022-29221/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-29221
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-29221
- OSV: https://osv.dev/vulnerability/CVE-2022-29221

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-29221/
Summaries are generated and may contain mistakes; the official description above is the record.
