# CVE-2022-29222: Improper Certificate Validation in Pion DTLS

> Attackers can bypass client certificate validation in Pion DTLS by providing certificates without private keys, affecting applications using client certificates.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 May 2022
- **Updated:** 23 Apr 2025
- **Also known as:** DEBIAN-CVE-2022-29222, GHSA-w45j-f832-hxvh, GO-2022-0462, UBUNTU-CVE-2022-29222

## What is CVE-2022-29222?

CVE-2022-29222 is a medium-severity vulnerability in pion dtls, published on 21 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Pion DTLS is a Go implementation of Datagram Transport Layer Security. Prior to version 2.1.5, a DTLS Client could provide a Certificate that it doesn't posses the private key for and Pion DTLS wouldn't reject it. This issue affects users that are using Client certificates only. The connection itself is still secure. The Certificate provided by clients can't be trusted when using a Pion DTLS server prior to version 2.1.5. Users should upgrade to version 2.1.5 to receive a patch. There are currently no known workarounds.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2022-29222?

5 open source packages ship an affected version, including github.com/pion/dtls/v2 and github.com/pion/dtls. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/pion/dtls/v2` | Go | All versions | 2.1.5 |
| `github.com/pion/dtls/v2` | Go | All versions | 2.1.5 |
| `github.com/pion/dtls/v2` | Go | All versions | 2.1.5 |
| `github.com/pion/dtls` | Go | All versions | 2.1.5 |
| `github.com/pion/dtls` | Go | All versions | 2.1.5 |

Products: Pion Dtls.

## How do I fix CVE-2022-29222?

Upgrade github.com/pion/dtls/v2 to 2.1.5 or later.

## Is CVE-2022-29222 being exploited?

There is no known exploitation of CVE-2022-29222 in the wild and no public exploit code.

## Other vulnerabilities in pion dtls

- [CVE-2019-20786](https://insights.sbomify.com/CVE-2019-20786/): Improper Authenication in Pion DTLS (critical 9.8)
- [CVE-2022-29190](https://insights.sbomify.com/CVE-2022-29190/): Header reconstruction method can be thrown into an infinite loop in Pion DTLS (high 7.5)
- [CVE-2026-26014](https://insights.sbomify.com/CVE-2026-26014/): Pion DTLS uses random nonce generation with AES GCM ciphers risks leaking the authentication key (medium 5.9)
- [CVE-2022-29189](https://insights.sbomify.com/CVE-2022-29189/): Buffer for inbound DTLS fragments has no limit (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-29222 and fix it if it is affected.

What it is: CVE-2022-29222 is a medium-severity vulnerability in pion dtls, published on 21 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-29222 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/pion/dtls/v2 (Go): affected all versions; fixed in 2.1.5
- github.com/pion/dtls/v2 (Go): affected all versions; fixed in 2.1.5
- github.com/pion/dtls/v2 (Go): affected all versions; fixed in 2.1.5
- github.com/pion/dtls (Go): affected all versions; fixed in 2.1.5
- github.com/pion/dtls (Go): affected all versions; fixed in 2.1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-29222/ (Markdown: https://insights.sbomify.com/CVE-2022-29222/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-29222
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-29222
- OSV: https://osv.dev/vulnerability/CVE-2022-29222

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-29222/
Summaries are generated and may contain mistakes; the official description above is the record.
