# CVE-2022-29228: Reachable assertion in Envoy

> Attackers can trigger a reachable assertion in the Envoy OAuth filter, causing memory corruption and potential denial of service or code execution.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jun 2022
- **Updated:** 23 Apr 2025
- **Also known as:** BIT-envoy-2022-29228, GHSA-rww6-8h7g-8jf6

## What is CVE-2022-29228?

CVE-2022-29228 is a high-severity use after free vulnerability in Envoyproxy Envoy, published on 9 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Envoy is a cloud-native high-performance proxy. In versions prior to 1.22.1 the OAuth filter would try to invoke the remaining filters in the chain after emitting a local response, which triggers an ASSERT() in newer versions and corrupts memory on earlier versions. continueDecoding() shouldn’t ever be called from filters after a local reply has been sent. Users are advised to upgrade. There are no known workarounds for this issue.

Weakness: CWE-416 (Use After Free), CWE-617 (Reachable Assertion)

## Which versions are affected by CVE-2022-29228?

1 open source package ship an affected version, including envoy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `envoy` | Bitnami | All versions | 1.22.1 |

Products: Envoyproxy Envoy.

## How do I fix CVE-2022-29228?

Upgrade envoy to 1.22.1 or later.

## Is CVE-2022-29228 being exploited?

There is no known exploitation of CVE-2022-29228 in the wild and no public exploit code.

## Other vulnerabilities in Envoyproxy Envoy

- [CVE-2022-29226](https://insights.sbomify.com/CVE-2022-29226/): Trivial authentication bypass in Envoy (critical 10.0)
- [CVE-2019-18801](https://insights.sbomify.com/CVE-2019-18801/): Memory corruption in n/a (critical 9.8)
- [CVE-2019-18802](https://insights.sbomify.com/CVE-2019-18802/): Security feature bypass in n/a (critical 9.8)
- [CVE-2020-35470](https://insights.sbomify.com/CVE-2020-35470/): Information disclosure in n/a (high 8.8)
- [CVE-2024-23324](https://insights.sbomify.com/CVE-2024-23324/): Envoy ext auth can be bypassed when Proxy protocol filter sets invalid UTF-8 metadata (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-29228 and fix it if it is affected.

What it is: CVE-2022-29228 is a high-severity use after free vulnerability in Envoyproxy Envoy, published on 9 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-29228 in the wild and no public exploit code.

Affected packages and fixed versions:
- envoy (Bitnami): affected all versions; fixed in 1.22.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-29228/ (Markdown: https://insights.sbomify.com/CVE-2022-29228/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-29228
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-29228
- OSV: https://osv.dev/vulnerability/CVE-2022-29228

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-29228/
Summaries are generated and may contain mistakes; the official description above is the record.
