# CVE-2022-29229: Missing Cryptographic Step in cassproject

> A missing cryptographic step allows server administrators to access user cryptographic keys in CaSS libraries using standalone authentication.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 May 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-7qcx-4p32-qcmx

## What is CVE-2022-29229?

CVE-2022-29229 is a medium-severity vulnerability in cassproject CASS, published on 18 May 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

CaSS is a Competency and Skills System. CaSS Library, (npm:cassproject) has a missing cryptographic step when storing cryptographic keys that can allow a server administrator access to an account’s cryptographic keys. This affects CaSS servers using standalone username/password authentication, which uses a method that expects e2e cryptographic security of authorization credentials. The issue has been patched in 1.5.8, however, the vulnerable accounts are only resecured when the user next logs in using standalone authentication, as the data required to resecure the account is not available to the server. The issue may be mitigated by using SSO or client side certificates to log in. Please note that SSO and client side certificate authentication does not have this expectation of no-knowledge credential access, and cryptographic keys are available to the server administrator.

Weakness: CWE-325 (Missing Cryptographic Step)

## Which versions are affected by CVE-2022-29229?

2 open source packages ship an affected version, including cassproject. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cassproject` | npm | All versions | 1.5.8 |
| `cassproject` | npm | All versions | 1.5.8 |

Products: Cassproject Competency and Skills System.

## How do I fix CVE-2022-29229?

Upgrade cassproject to 1.5.8 or later.

## Is CVE-2022-29229 being exploited?

There is no known exploitation of CVE-2022-29229 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-29229 and fix it if it is affected.

What it is: CVE-2022-29229 is a medium-severity vulnerability in cassproject CASS, published on 18 May 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-29229 in the wild and no public exploit code.

Affected packages and fixed versions:
- cassproject (npm): affected all versions; fixed in 1.5.8
- cassproject (npm): affected all versions; fixed in 1.5.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-29229/ (Markdown: https://insights.sbomify.com/CVE-2022-29229/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-29229
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-29229
- OSV: https://osv.dev/vulnerability/CVE-2022-29229

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-29229/
Summaries are generated and may contain mistakes; the official description above is the record.
