# CVE-2022-29230: Potential cross-site scripting (XSS) vulnerability in Hydrogen


- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 18 May 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-6j22-wv8g-894f

## What is CVE-2022-29230?

CVE-2022-29230 is a medium-severity vulnerability in Shopify hydrogen, published on 18 May 2022. 

### Official description

Hydrogen is a React-based framework for building dynamic, Shopify-powered custom storefronts. There is a potential Cross-Site Scripting (XSS) vulnerability where an arbitrary user is able to execute scripts on pages that are built with Hydrogen. This affects all versions of Hydrogen starting from version 0.10.0 to 0.18.0. This vulnerability is exploitable in applications whose hydrating data is user controlled. All Hydrogen users should upgrade their project to version 0.19.0. There is no current workaround, and users should update as soon as possible. Additionally, the Content Security Policy is not an effective mitigation for this vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-29230?

2 open source packages ship an affected version, including @shopify/hydrogen. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@shopify/hydrogen` | npm | From 0.10.0 | 0.19.0 |
| `@shopify/hydrogen` | npm | From 0.10.0 | 0.19.0 |

Products: Shopify Hydrogen.

## How do I fix CVE-2022-29230?

Upgrade @shopify/hydrogen to 0.19.0 or later.

## Is CVE-2022-29230 being exploited?

There is no known exploitation of CVE-2022-29230 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-29230 and fix it if it is affected.

What it is: CVE-2022-29230 is a medium-severity vulnerability in Shopify hydrogen, published on 18 May 2022. 
Exploitation: There is no known exploitation of CVE-2022-29230 in the wild and no public exploit code.

Affected packages and fixed versions:
- @shopify/hydrogen (npm): affected from 0.10.0; fixed in 0.19.0
- @shopify/hydrogen (npm): affected from 0.10.0; fixed in 0.19.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-29230/ (Markdown: https://insights.sbomify.com/CVE-2022-29230/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-29230
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-29230
- OSV: https://osv.dev/vulnerability/CVE-2022-29230

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-29230/
Summaries are generated and may contain mistakes; the official description above is the record.
