# CVE-2022-29237: Limited Authentication Bypass for Media Files in Opencast

> Attackers with ingest access can import files from other organizations, bypassing tenant isolation in multi-tenant Opencast clusters.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 May 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-qm6v-cg9v-53j3

## What is CVE-2022-29237?

CVE-2022-29237 is a medium-severity authentication bypass vulnerability in opencast, published on 24 May 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Opencast is a free and open source solution for automated video capture and distribution at scale. Prior to Opencast 10.14 and 11.7, users could pass along URLs for files belonging to organizations other than the user's own, which Opencast would then import into the current organization, bypassing organizational barriers. Attackers must have full access to Opencast's ingest REST interface, and also know internal links to resources in another organization of the same Opencast cluster. Users who do not run a multi-tenant cluster are not affected by this issue. This issue is fixed in Opencast 10.14 and 11.7.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2022-29237?

4 open source packages ship an affected version, including org.opencastproject:opencast-ingest-service-impl. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.opencastproject:opencast-ingest-service-impl` | Maven | All versions | 10.14 |
| `org.opencastproject:opencast-ingest-service-impl` | Maven | All versions | 10.14 |
| `org.opencastproject:opencast-ingest-service-impl` | Maven | From 11.0 | 11.7 |
| `org.opencastproject:opencast-ingest-service-impl` | Maven | From 11.0 | 11.7 |

Products: Apereo Opencast.

## How do I fix CVE-2022-29237?

Upgrade org.opencastproject:opencast-ingest-service-impl to a fixed version for your release line: 10.14 or 11.7.

## Is CVE-2022-29237 being exploited?

There is no known exploitation of CVE-2022-29237 in the wild and no public exploit code.

## Other vulnerabilities in opencast

- [CVE-2021-43821](https://insights.sbomify.com/CVE-2021-43821/): Files Accessible to External Parties in Opencast (critical 9.9)
- [CVE-2020-5206](https://insights.sbomify.com/CVE-2020-5206/): Authentication Bypass For Endpoints With Anonymous Access in OpenCast (high 8.7)
- [CVE-2021-32623](https://insights.sbomify.com/CVE-2021-32623/): Opencast vulnerable to billion laughs attack (XML bomb) (high 8.1)
- [CVE-2020-5229](https://insights.sbomify.com/CVE-2020-5229/): Opencast stores passwords using outdated MD5 hash algorithm (high 7.7)
- [CVE-2020-5230](https://insights.sbomify.com/CVE-2020-5230/): Opencast uses unsafe identifiers (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-29237 and fix it if it is affected.

What it is: CVE-2022-29237 is a medium-severity authentication bypass vulnerability in opencast, published on 24 May 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-29237 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.opencastproject:opencast-ingest-service-impl (Maven): affected all versions; fixed in 10.14
- org.opencastproject:opencast-ingest-service-impl (Maven): affected all versions; fixed in 10.14
- org.opencastproject:opencast-ingest-service-impl (Maven): affected from 11.0; fixed in 11.7
- org.opencastproject:opencast-ingest-service-impl (Maven): affected from 11.0; fixed in 11.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-29237/ (Markdown: https://insights.sbomify.com/CVE-2022-29237/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-29237
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-29237
- OSV: https://osv.dev/vulnerability/CVE-2022-29237

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-29237/
Summaries are generated and may contain mistakes; the official description above is the record.
