# CVE-2022-29238: Forced Browsing in Jupyter Notebook

> Authenticated users can access hidden files despite configuration restrictions, potentially exposing sensitive data if file names are guessable.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jun 2022
- **Updated:** 23 Apr 2025
- **Also known as:** BIT-jupyter-base-notebook-2022-29238, BIT-jupyter-notebook-2022-29238, CLEANSTART-2026-IA17108, DEBIAN-CVE-2022-29238, GHSA-v7vq-3x77-87vg, PYSEC-2022-212, UBUNTU-CVE-2022-29238, openSUSE-SU-2024:12148-1

## What is CVE-2022-29238?

CVE-2022-29238 is a medium-severity missing authorization vulnerability in jupyter notebook, published on 14 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jupyter Notebook is a web-based notebook environment for interactive computing. Prior to version 6.4.12, authenticated requests to the notebook server with `ContentsManager.allow_hidden = False` only prevented listing the contents of hidden directories, not accessing individual hidden files or files in hidden directories (i.e. hidden files were 'hidden' but not 'inaccessible'). This could lead to notebook configurations allowing authenticated access to files that may reasonably be expected to be disallowed. Because fully authenticated requests are required, this is of relatively low impact. But if a server's root directory contains sensitive files whose only protection from the server is being hidden (e.g. `~/.ssh` while serving $HOME), then any authenticated requests could access files if their names are guessable. Such contexts also necessarily have full access to the server and therefore execution permissions, which also generally grants access to all the same files. So this does not generally result in any privilege escalation or increase in information access, only an additional, unintended means by which the files could be accessed. Version 6.4.12 contains a patch for this issue. There are currently no known workarounds.

Weakness: CWE-425 (Direct Request)

## Which versions are affected by CVE-2022-29238?

5 open source packages ship an affected version, including jupyter-base-notebook, jupyter-notebook and notebook. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jupyter-base-notebook` | Bitnami | All versions | 6.4.12 |
| `jupyter-notebook` | Bitnami | All versions | 6.4.12 |
| `notebook` | PyPI | All versions | 6.4.12 |
| `notebook` | PyPI | All versions | 6.4.12 |
| `notebook` | PyPI | All versions | 6.4.12 |

Products: Jupyter Notebook.

## How do I fix CVE-2022-29238?

Upgrade jupyter-base-notebook to 6.4.12 or later.

## Is CVE-2022-29238 being exploited?

There is no known exploitation of CVE-2022-29238 in the wild and no public exploit code.

## Other vulnerabilities in jupyter notebook

- [CVE-2021-32798](https://insights.sbomify.com/CVE-2021-32798/): Failure to Sanitize Special Elements into a Different Plane (Special Element Injection) in notebook (critical 10.0)
- [CVE-2018-8768](https://insights.sbomify.com/CVE-2018-8768/): Jupyter Notebook file bypasses sanitization, executes JavaScript (high 7.8)
- [CVE-2022-24758](https://insights.sbomify.com/CVE-2022-24758/): Insertion of Sensitive Information into Log File affects Jupyter Notebook (high 7.5)
- [CVE-2019-10856](https://insights.sbomify.com/CVE-2019-10856/): Jupyter Notebook open redirect vulnerability (medium 6.1)
- [CVE-2018-19351](https://insights.sbomify.com/CVE-2018-19351/): Jupyter Notebook XSS via untrusted notebooks (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-29238 and fix it if it is affected.

What it is: CVE-2022-29238 is a medium-severity missing authorization vulnerability in jupyter notebook, published on 14 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-29238 in the wild and no public exploit code.

Affected packages and fixed versions:
- jupyter-base-notebook (Bitnami): affected all versions; fixed in 6.4.12
- jupyter-notebook (Bitnami): affected all versions; fixed in 6.4.12
- notebook (PyPI): affected all versions; fixed in 6.4.12
- notebook (PyPI): affected all versions; fixed in 6.4.12
- notebook (PyPI): affected all versions; fixed in 6.4.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-29238/ (Markdown: https://insights.sbomify.com/CVE-2022-29238/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-29238
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-29238
- OSV: https://osv.dev/vulnerability/CVE-2022-29238

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-29238/
Summaries are generated and may contain mistakes; the official description above is the record.
