CVE-2022-29241 Known or guessable hidden files may be accessed in Jupyter Server
An authenticated attacker can leak the Jupyter access token via hidden files, enabling data theft and potential system control.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-29241?
CVE-2022-29241 is a high-severity vulnerability in jupyter-server jupyter_server, published on 14 Jun 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Jupyter Server provides the backend (i.e. the core services, APIs, and REST endpoints) for Jupyter web applications like Jupyter Notebook. Prior to version 1.17.1, if notebook server is started with a value of `root_dir` that contains the starting user's home directory, then the underlying REST API can be used to leak the access token assigned at start time by guessing/brute forcing the PID of the jupyter server. While this requires an authenticated user session, this URL can be used from a cross-site scripting payload or from a hooked or otherwise compromised browser to leak this access token to a malicious third party. This token can be used along with the REST API to interact with Jupyter services/notebooks such as modifying or overwriting critical files, such as .bashrc or .ssh/authorized_keys, allowing a malicious user to read potentially sensitive data and possibly gain control of the impacted system. This issue is patched in version 1.17.1.
Weakness: CWE-200
Which versions are affected by CVE-2022-29241?
5 open source packages ship an affected version, including jupyter-server. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
jupyter-server PyPI | All versions | 1.17.0 |
jupyter-server PyPI | All versions | 1.17.1 |
jupyter-server PyPI | All versions | 1.17.1 |
jupyter-server PyPI | From 2.0.0a0 | 2.0.0a1 |
jupyter-server PyPI | From 2.0.0a0 | 2.0.0a1 |
Linux distribution packages (1)
python-jupyter-server openSUSE:Tumbleweed | All versions | 2.14.2-3.1 |
Products include Jupyter Jupyter Server.
How do I fix CVE-2022-29241?
Upgrade jupyter-server to a fixed version for your release line: 1.17.0, 1.17.1 or 2.0.0a1.
Is CVE-2022-29241 being exploited?
There is no known exploitation of CVE-2022-29241 in the wild and no public exploit code.
Other vulnerabilities in jupyter-server jupyter_server
- CVE-2026-44727 Jupyter Server: Stored XSS in `NbconvertFileHandler` / `NbconvertPostHandler` via missing `sandbox` CSP
- CVE-2026-35397 jupyter-server path traversal allows access to sibling directories sharing root_dir name prefix
- CVE-2026-40110 jupyter-server CORS origin validation bypass via unanchored regex in allow_origin_pat
- CVE-2026-40934 jupyter-server authentication cookies remain valid after password reset due to static cookie secret
- CVE-2024-35178 Jupyter server on Windows discloses Windows user password hash
Sources
Also known as DEBIAN-CVE-2022-29241, GHSA-q874-g24w-4q9g, PYSEC-2022-211, UBUNTU-CVE-2022-29241, openSUSE-SU-2024:12147-1, openSUSE-SU-2025:14845-1.