{"answers":{"affected":"2 open source packages ship an affected version, including npm. It affects 2 products.","exploited":"There is no known exploitation of CVE-2022-29244 in the wild and no public exploit code.","fix":"Upgrade npm to 8.11.0 or later.","what":"CVE-2022-29244 is a high-severity vulnerability in Netapp Ontap Select Deploy Administration Utility, published on 13 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-29244 and fix it if it is affected.\n\nWhat it is: CVE-2022-29244 is a high-severity vulnerability in Netapp Ontap Select Deploy Administration Utility, published on 13 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-29244 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- npm (npm): affected from 7.9.0; fixed in 8.11.0\n- npm (npm): affected from 7.9.0; fixed in 8.11.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-29244/ (Markdown: https://insights.sbomify.com/CVE-2022-29244/index.md)","id":"CVE-2022-29244","markdown":"https://insights.sbomify.com/CVE-2022-29244/index.md","name":"CVE-2022-29244","record":{"aliases":["GHSA-hj9c-8jmm-8c52","UBUNTU-CVE-2022-29244","openSUSE-SU-2024:12280-1"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"npm package manager","requires_auth":"none","summary":"npm pack fails to respect root ignore files in workspaces, potentially exposing unintended files in published packages.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"ontap_select_deploy_administration_utility","vendor":"netapp"},{"product":"npm","vendor":"npmjs"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"npm pack ignores root-level .gitignore and .npmignore file exclusion directives when run in a workspace or with a workspace flag (ie. `--workspaces`, `--workspace=\u003cname\u003e`). Anyone who has run `npm pack` or `npm publish` inside a workspace, as of v7.9.0 and v7.13.0 respectively, may be affected and have published files into the npm registry they did not intend to include. Users should upgrade to the latest, patched version of npm v8.11.0, run: npm i -g npm@latest . Node.js versions v16.15.1, v17.19.1, and v18.3.0 include the patched v8.11.0 version of npm.","ecosystems":["npm","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"npm packing does not respect root-level ignore files in workspaces","id":"CVE-2022-29244","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"netapp:ontap_select_deploy_administration_utility","products":["netapp:ontap_select_deploy_administration_utility"],"type":"information_disclosure","year":"2022"},"n_packages":3,"n_references":10,"next":{"headline":"Weak private key generation in SSH.NET","id":"CVE-2022-29245"},"packages":[{"ecosystem":"npm","fixed":["8.11.0"],"introduced":["7.9.0"],"last_affected":[],"package":"npm","purl":null,"source":"GHSA-hj9c-8jmm-8c52"},{"ecosystem":"npm","fixed":["8.11.0"],"introduced":["7.9.0"],"last_affected":[],"package":"npm","purl":"pkg:npm/npm","source":"GHSA-hj9c-8jmm-8c52"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["16.17.0-1.1"],"introduced":["0"],"last_affected":[],"package":"nodejs16","purl":"pkg:rpm/opensuse/nodejs16\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:12280-1"}],"prev":{"headline":"Improper input-size validation on the user new session name in Nextcloud Server","id":"CVE-2022-29243"},"products":["npm"],"published":"2022-06-13","related":[{"cvss_score":9.8,"headline":"Memory corruption in sqlite","id":"CVE-2020-35527","kev_date_added":null,"published":"2022-09-01"},{"cvss_score":9.8,"headline":"Use after free in n/a","id":"CVE-2020-11656","kev_date_added":null,"published":"2020-04-09"},{"cvss_score":9.8,"headline":"Code injection in ONTAP Select Deploy administration utility","id":"CVE-2019-5509","kev_date_added":null,"published":"2019-11-21"},{"cvss_score":9.8,"headline":"Missing authorization in ONTAP Select Deploy administration utility","id":"CVE-2019-5504","kev_date_added":null,"published":"2019-09-24"},{"cvss_score":9.8,"headline":"Information disclosure in ONTAP Select Deploy administration utility","id":"CVE-2019-5505","kev_date_added":null,"published":"2019-09-24"},{"cvss_score":8.1,"headline":"Privilege Escalation Vulnerability in ONTAP Select Deploy administration utility","id":"CVE-2024-21989","kev_date_added":null,"published":"2024-04-17"},{"cvss_score":7.8,"headline":"Use After Free in vim/vim","id":"CVE-2022-4292","kev_date_added":null,"published":"2022-12-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["npm"]},"summary":"npm pack fails to respect root ignore files in workspaces, potentially exposing unintended files in published packages.","url":"https://insights.sbomify.com/CVE-2022-29244/"}