# CVE-2022-29244: npm packing does not respect root-level ignore files in workspaces

> npm pack fails to respect root ignore files in workspaces, potentially exposing unintended files in published packages.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jun 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-hj9c-8jmm-8c52, UBUNTU-CVE-2022-29244, openSUSE-SU-2024:12280-1

## What is CVE-2022-29244?

CVE-2022-29244 is a high-severity vulnerability in Netapp Ontap Select Deploy Administration Utility, published on 13 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

npm pack ignores root-level .gitignore and .npmignore file exclusion directives when run in a workspace or with a workspace flag (ie. `--workspaces`, `--workspace=<name>`). Anyone who has run `npm pack` or `npm publish` inside a workspace, as of v7.9.0 and v7.13.0 respectively, may be affected and have published files into the npm registry they did not intend to include. Users should upgrade to the latest, patched version of npm v8.11.0, run: npm i -g npm@latest . Node.js versions v16.15.1, v17.19.1, and v18.3.0 include the patched v8.11.0 version of npm.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2022-29244?

2 open source packages ship an affected version, including npm. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `npm` | npm | From 7.9.0 | 8.11.0 |
| `npm` | npm | From 7.9.0 | 8.11.0 |
| `nodejs16` | openSUSE:Tumbleweed | All versions | 16.17.0-1.1 |

Products: Netapp Ontap Select Deploy Administration Utility, Npmjs Npm.

## How do I fix CVE-2022-29244?

Upgrade npm to 8.11.0 or later.

## Is CVE-2022-29244 being exploited?

There is no known exploitation of CVE-2022-29244 in the wild and no public exploit code.

## Other vulnerabilities in Netapp Ontap Select Deploy Administration Utility

- [CVE-2020-35527](https://insights.sbomify.com/CVE-2020-35527/): Memory corruption in sqlite (critical 9.8)
- [CVE-2020-11656](https://insights.sbomify.com/CVE-2020-11656/): Use after free in n/a (critical 9.8)
- [CVE-2019-5509](https://insights.sbomify.com/CVE-2019-5509/): Code injection in ONTAP Select Deploy administration utility (critical 9.8)
- [CVE-2019-5504](https://insights.sbomify.com/CVE-2019-5504/): Missing authorization in ONTAP Select Deploy administration utility (critical 9.8)
- [CVE-2019-5505](https://insights.sbomify.com/CVE-2019-5505/): Information disclosure in ONTAP Select Deploy administration utility (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-29244 and fix it if it is affected.

What it is: CVE-2022-29244 is a high-severity vulnerability in Netapp Ontap Select Deploy Administration Utility, published on 13 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-29244 in the wild and no public exploit code.

Affected packages and fixed versions:
- npm (npm): affected from 7.9.0; fixed in 8.11.0
- npm (npm): affected from 7.9.0; fixed in 8.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-29244/ (Markdown: https://insights.sbomify.com/CVE-2022-29244/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-29244
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-29244
- OSV: https://osv.dev/vulnerability/CVE-2022-29244

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-29244/
Summaries are generated and may contain mistakes; the official description above is the record.
