CVE-2022-29247 Exposure of Resource to Wrong Sphere in Electron
Attackers can access privileged IPC channels in sandboxed Electron apps if nodeIntegrationInSubFrames is enabled and senderFrame validation is missing.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-29247?
CVE-2022-29247 is a low-severity missing authorization vulnerability in Electronjs Electron, published on 13 Jun 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Electron is a framework for writing cross-platform desktop applications using JavaScript (JS), HTML, and CSS. A vulnerability in versions prior to 18.0.0-beta.6, 17.2.0, 16.2.6, and 15.5.5 allows a renderer with JS execution to obtain access to a new renderer process with `nodeIntegrationInSubFrames` enabled which in turn allows effective access to `ipcRenderer`. The `nodeIntegrationInSubFrames` option does not implicitly grant Node.js access. Rather, it depends on the existing sandbox setting. If an application is sandboxed, then `nodeIntegrationInSubFrames` just gives access to the sandboxed renderer APIs, which include `ipcRenderer`. If the application then additionally exposes IPC messages without IPC `senderFrame` validation that perform privileged actions or return confidential data this access to `ipcRenderer` can in turn compromise your application / user even with the sandbox enabled. Electron versions 18.0.0-beta.6, 17.2.0, 16.2.6, and 15.5.5 contain a fix for this issue. As a workaround, ensure that all IPC message handlers appropriately validate `senderFrame`.
Weakness: CWE-668
Which versions are affected by CVE-2022-29247?
8 open source packages ship an affected version, including electron. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
electron npm | All versions | 15.5.5 |
electron npm | All versions | 15.5.5 |
electron npm | From 16.0.0 | 16.2.6 |
electron npm | From 16.0.0 | 16.2.6 |
electron npm | From 17.0.0 | 17.2.0 |
electron npm | From 17.0.0 | 17.2.0 |
2 more packages
electron npm | From 18.0.0-beta.1 | 18.0.0-beta.6 |
electron npm | From 18.0.0-beta.1 | 18.0.0-beta.6 |
Products include Electronjs Electron.
How do I fix CVE-2022-29247?
Upgrade electron to a fixed version for your release line: 15.5.5, 16.2.6, 17.2.0 or 18.0.0-beta.6.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2022-29247 being exploited?
There is no known exploitation of CVE-2022-29247 in the wild and no public exploit code.
Other vulnerabilities in Electronjs Electron
- CVE-2017-16151 Chromium Remote Code Execution in electron
- CVE-2018-1000118 Electron protocol handler browser vulnerable to Command Injection
- CVE-2026-34780 Electron: Context Isolation bypass via contextBridge VideoFrame transfer
- CVE-2026-102676 Electron: <webview> can enable Node.js integration in Web Workers despite embedder restrictions
- CVE-2026-102673 Electron drops inherited HTML sandbox restrictions for popups opened through OpenURLFromTab
Sources
Also known as GHSA-mq8j-3h7h-p8g7.