CVE-2022-29248 Cross-domain cookie leakage in Guzzle
A malicious server can set cookies for unrelated domains in Guzzle, potentially leaking sensitive data to attackers.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-29248?
CVE-2022-29248 is a high-severity vulnerability in Debian Debian Linux, published on 25 May 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Guzzle is a PHP HTTP client. Guzzle prior to versions 6.5.6 and 7.4.3 contains a vulnerability with the cookie middleware. The vulnerability is that it is not checked if the cookie domain equals the domain of the server which sets the cookie via the Set-Cookie header, allowing a malicious server to set cookies for unrelated domains. The cookie middleware is disabled by default, so most library consumers will not be affected by this issue. Only those who manually add the cookie middleware to the handler stack or construct the client with ['cookies' => true] are affected. Moreover, those who do not use the same Guzzle client to call multiple domains and have disabled redirect forwarding are not affected by this vulnerability. Guzzle versions 6.5.6 and 7.4.3 contain a patch for this issue. As a workaround, turn off the cookie middleware.
Which versions are affected by CVE-2022-29248?
6 open source packages ship an affected version, including guzzlehttp/guzzle, drupal and drupal/core. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
guzzlehttp/guzzle Packagist | All versions | 6.5.6 |
guzzlehttp/guzzle Packagist | All versions | 6.5.6 |
guzzlehttp/guzzle Packagist | From 7.0.0 | 7.4.3 |
guzzlehttp/guzzle Packagist | From 7.0.0 | 7.4.3 |
drupal Bitnami | From 9.2.0 | 9.2.20, 9.3.14 |
drupal/core Packagist | From 8.0.0 | 9.2.20, 9.3.14 |
Products include Debian Debian Linux, Drupal Drupal, Guzzlephp Guzzle.
How do I fix CVE-2022-29248?
Upgrade guzzlehttp/guzzle to a fixed version for your release line: 6.5.6 or 7.4.3.
Is CVE-2022-29248 being exploited?
There is no known exploitation of CVE-2022-29248 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-drupal-2022-29248, DEBIAN-CVE-2022-29248, DRUPAL-CORE-2022-010, GHSA-cwmx-hcrq-mhc3, UBUNTU-CVE-2022-29248.