# CVE-2022-29248: Cross-domain cookie leakage in Guzzle

> A malicious server can set cookies for unrelated domains in Guzzle, potentially leaking sensitive data to attackers.

- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 May 2022
- **Updated:** 23 Apr 2025
- **Also known as:** BIT-drupal-2022-29248, DEBIAN-CVE-2022-29248, DRUPAL-CORE-2022-010, GHSA-cwmx-hcrq-mhc3, UBUNTU-CVE-2022-29248

## What is CVE-2022-29248?

CVE-2022-29248 is a high-severity vulnerability in Debian Debian Linux, published on 25 May 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Guzzle is a PHP HTTP client. Guzzle prior to versions 6.5.6 and 7.4.3 contains a vulnerability with the cookie middleware. The vulnerability is that it is not checked if the cookie domain equals the domain of the server which sets the cookie via the Set-Cookie header, allowing a malicious server to set cookies for unrelated domains. The cookie middleware is disabled by default, so most library consumers will not be affected by this issue. Only those who manually add the cookie middleware to the handler stack or construct the client with ['cookies' => true] are affected. Moreover, those who do not use the same Guzzle client to call multiple domains and have disabled redirect forwarding are not affected by this vulnerability. Guzzle versions 6.5.6 and 7.4.3 contain a patch for this issue. As a workaround, turn off the cookie middleware.

Weakness: CWE-565 (Reliance on Cookies without Validation and Integrity Checking), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2022-29248?

6 open source packages ship an affected version, including guzzlehttp/guzzle, drupal and drupal/core. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `guzzlehttp/guzzle` | Packagist | All versions | 6.5.6 |
| `guzzlehttp/guzzle` | Packagist | All versions | 6.5.6 |
| `guzzlehttp/guzzle` | Packagist | From 7.0.0 | 7.4.3 |
| `guzzlehttp/guzzle` | Packagist | From 7.0.0 | 7.4.3 |
| `drupal` | Bitnami | From 9.2.0 | 9.2.20, 9.3.14 |
| `drupal/core` | Packagist | From 8.0.0 | 9.2.20, 9.3.14 |

Products: Debian Debian Linux, Drupal Drupal, Guzzlephp Guzzle.

## How do I fix CVE-2022-29248?

Upgrade guzzlehttp/guzzle to a fixed version for your release line: 6.5.6 or 7.4.3.

## Is CVE-2022-29248 being exploited?

There is no known exploitation of CVE-2022-29248 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-29248 and fix it if it is affected.

What it is: CVE-2022-29248 is a high-severity vulnerability in Debian Debian Linux, published on 25 May 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-29248 in the wild and no public exploit code.

Affected packages and fixed versions:
- guzzlehttp/guzzle (Packagist): affected all versions; fixed in 6.5.6
- guzzlehttp/guzzle (Packagist): affected all versions; fixed in 6.5.6
- guzzlehttp/guzzle (Packagist): affected from 7.0.0; fixed in 7.4.3
- guzzlehttp/guzzle (Packagist): affected from 7.0.0; fixed in 7.4.3
- drupal (Bitnami): affected from 9.2.0; fixed in 9.2.20, 9.3.14
- drupal/core (Packagist): affected from 8.0.0; fixed in 9.2.20, 9.3.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-29248/ (Markdown: https://insights.sbomify.com/CVE-2022-29248/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-29248
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-29248
- OSV: https://osv.dev/vulnerability/CVE-2022-29248

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-29248/
Summaries are generated and may contain mistakes; the official description above is the record.
