{"answers":{"affected":"2 open source packages ship an affected version, including io.github.javaezlib:JavaEZ. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-29249 in the wild and no public exploit code.","fix":"Upgrade io.github.javaezlib:JavaEZ to 1.7 or later.","what":"CVE-2022-29249 is a high-severity vulnerability in JavaEZLib JavaEZ, published on 24 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-29249 and fix it if it is affected.\n\nWhat it is: CVE-2022-29249 is a high-severity vulnerability in JavaEZLib JavaEZ, published on 24 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-29249 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- io.github.javaezlib:JavaEZ (Maven): affected from 1.6; fixed in 1.7\n- io.github.javaezlib:JavaEZ (Maven): affected from 1.6; fixed in 1.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-29249/ (Markdown: https://insights.sbomify.com/CVE-2022-29249/index.md)","id":"CVE-2022-29249","markdown":"https://insights.sbomify.com/CVE-2022-29249/index.md","name":"CVE-2022-29249","record":{"aliases":["GHSA-67fj-6w6m-w5j8"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Java utility library","requires_auth":"none","summary":"Attackers can decrypt locked text due to weak cryptographic algorithms in the JavaEZ library, compromising data confidentiality.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"javaez","vendor":"javaez_project"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-326","name":"Inadequate Encryption Strength"},{"id":"CWE-328","name":"Use of Weak Hash"},{"id":"CWE-327","name":"Use of a Broken or Risky Cryptographic Algorithm"}],"description":"JavaEZ is a library that adds new functions to make Java easier. A weakness in JavaEZ 1.6 allows force decryption of locked text by unauthorized actors. The issue is NOT critical for non-secure applications, however may be critical in a situation where the highest levels of security are required. This issue ONLY affects v1.6 and does not affect anything pre-1.6. The vulnerability has been patched in release 1.7. Currently, there is no way to fix the issue without upgrading.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Reversible One-Way Hash and Use of a Broken or Risky Cryptographic Algorithm in io.github.javaezlib.JavaEZ","id":"CVE-2022-29249","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"weak_cryptography","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"SQL injection in GLPI","id":"CVE-2022-29250"},"packages":[{"ecosystem":"Maven","fixed":["1.7"],"introduced":["1.6"],"last_affected":[],"package":"io.github.javaezlib:JavaEZ","purl":null,"source":"GHSA-67fj-6w6m-w5j8"},{"ecosystem":"Maven","fixed":["1.7"],"introduced":["1.6"],"last_affected":[],"package":"io.github.javaezlib:JavaEZ","purl":"pkg:maven/io.github.javaezlib/JavaEZ","source":"GHSA-67fj-6w6m-w5j8"}],"prev":{"headline":"Cross-domain cookie leakage in Guzzle","id":"CVE-2022-29248"},"products":["JavaEZ"],"published":"2022-05-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["JavaEZLib"]},"summary":"Attackers can decrypt locked text due to weak cryptographic algorithms in the JavaEZ library, compromising data confidentiality.","url":"https://insights.sbomify.com/CVE-2022-29249/"}