# CVE-2022-29249: Reversible One-Way Hash and Use of a Broken or Risky Cryptographic Algorithm in io.github.javaezlib.JavaEZ

> Attackers can decrypt locked text due to weak cryptographic algorithms in the JavaEZ library, compromising data confidentiality.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 May 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-67fj-6w6m-w5j8

## What is CVE-2022-29249?

CVE-2022-29249 is a high-severity vulnerability in JavaEZLib JavaEZ, published on 24 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

JavaEZ is a library that adds new functions to make Java easier. A weakness in JavaEZ 1.6 allows force decryption of locked text by unauthorized actors. The issue is NOT critical for non-secure applications, however may be critical in a situation where the highest levels of security are required. This issue ONLY affects v1.6 and does not affect anything pre-1.6. The vulnerability has been patched in release 1.7. Currently, there is no way to fix the issue without upgrading.

Weakness: CWE-326 (Inadequate Encryption Strength), CWE-328 (Use of Weak Hash), CWE-327 (Use of a Broken or Risky Cryptographic Algorithm)

## Which versions are affected by CVE-2022-29249?

2 open source packages ship an affected version, including io.github.javaezlib:JavaEZ. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.github.javaezlib:JavaEZ` | Maven | From 1.6 | 1.7 |
| `io.github.javaezlib:JavaEZ` | Maven | From 1.6 | 1.7 |

Products: Javaez Project Javaez.

## How do I fix CVE-2022-29249?

Upgrade io.github.javaezlib:JavaEZ to 1.7 or later.

## Is CVE-2022-29249 being exploited?

There is no known exploitation of CVE-2022-29249 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-29249 and fix it if it is affected.

What it is: CVE-2022-29249 is a high-severity vulnerability in JavaEZLib JavaEZ, published on 24 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-29249 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.github.javaezlib:JavaEZ (Maven): affected from 1.6; fixed in 1.7
- io.github.javaezlib:JavaEZ (Maven): affected from 1.6; fixed in 1.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-29249/ (Markdown: https://insights.sbomify.com/CVE-2022-29249/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-29249
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-29249
- OSV: https://osv.dev/vulnerability/CVE-2022-29249

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-29249/
Summaries are generated and may contain mistakes; the official description above is the record.
