CVE-2022-29253 Path Traversal in XWiki Platform

Low 2.7 Published Updated

Attackers can read arbitrary files from the classloader via path traversal in the template API, exposing sensitive application data.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-29253?

CVE-2022-29253 is a low-severity path traversal vulnerability in Xwiki Xwiki, published on 25 May 2022. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Starting with version 8.3-rc-1 and prior to versions 12.10.3 and 14.0, one can ask for any file located in the classloader using the template API and a path with ".." in it. The issue is patched in versions 14.0 and 13.10.3. There is no easy workaround for this issue.

Weakness: CWE-24, CWE-22

Which versions are affected by CVE-2022-29253?

2 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-oldcore. It affects 1 product.

PackageAffectedFixed in
org.xwiki.platform:xwiki-platform-oldcore MavenFrom 8.3-rc-113.10.3
org.xwiki.platform:xwiki-platform-oldcore MavenFrom 8.3-rc-113.10.3

Products include Xwiki Xwiki.

How do I fix CVE-2022-29253?

Upgrade org.xwiki.platform:xwiki-platform-oldcore to 13.10.3 or later.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2022-29253 being exploited?

There is no known exploitation of CVE-2022-29253 in the wild and no public exploit code.

All Xwiki Xwiki vulnerabilities

Sources

Also known as GHSA-9qrp-h7fw-42hg.

Is CVE-2022-29253 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free