CVE-2022-29257 Electron's AutoUpdater module fails to validate certain nested components of the bundle
Attackers controlling update servers can serve maliciously crafted packages that bypass code signing, leading to arbitrary code execution in Electron applications.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-29257?
CVE-2022-29257 is a medium-severity code injection vulnerability in Electronjs Electron, published on 13 Jun 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Electron is a framework for writing cross-platform desktop applications using JavaScript (JS), HTML, and CSS. A vulnerability in versions prior to 18.0.0-beta.6, 17.2.0, 16.2.6, and 15.5.5 allows attackers who have control over a given apps update server / update storage to serve maliciously crafted update packages that pass the code signing validation check but contain malicious code in some components. This kind of attack would require significant privileges in a potential victim's own auto updating infrastructure and the ease of that attack entirely depends on the potential victim's infrastructure security. Electron versions 18.0.0-beta.6, 17.2.0, 16.2.6, and 15.5.5 contain a fix for this issue. There are no known workarounds.
Weakness: CWE-20
Which versions are affected by CVE-2022-29257?
8 open source packages ship an affected version, including electron. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
electron npm | All versions | 15.5.0 |
electron npm | All versions | 15.5.0 |
electron npm | From 16.0.0 | 16.2.0 |
electron npm | From 16.0.0 | 16.2.0 |
electron npm | From 17.0.0 | 17.2.0 |
electron npm | From 17.0.0 | 17.2.0 |
2 more packages
electron npm | From 18.0.0-beta.1 | 18.0.0-beta.6 |
electron npm | From 18.0.0-beta.1 | 18.0.0-beta.6 |
Products include Electronjs Electron.
How do I fix CVE-2022-29257?
Upgrade electron to a fixed version for your release line: 15.5.0, 16.2.0, 17.2.0 or 18.0.0-beta.6.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2022-29257 being exploited?
There is no known exploitation of CVE-2022-29257 in the wild and no public exploit code.
Other vulnerabilities in Electronjs Electron
- CVE-2017-16151 Chromium Remote Code Execution in electron
- CVE-2018-1000118 Electron protocol handler browser vulnerable to Command Injection
- CVE-2026-34780 Electron: Context Isolation bypass via contextBridge VideoFrame transfer
- CVE-2026-102676 Electron: <webview> can enable Node.js integration in Web Workers despite embedder restrictions
- CVE-2026-102673 Electron drops inherited HTML sandbox restrictions for popups opened through OpenURLFromTab
Sources
Also known as GHSA-77xc-hjv8-ww97.