# CVE-2022-29257: Electron's AutoUpdater module fails to validate certain nested components of the bundle

> Attackers controlling update servers can serve maliciously crafted packages that bypass code signing, leading to arbitrary code execution in Electron applications.

- **Severity:** Medium 6.6 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jun 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-77xc-hjv8-ww97

## What is CVE-2022-29257?

CVE-2022-29257 is a medium-severity code injection vulnerability in Electronjs Electron, published on 13 Jun 2022. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Electron is a framework for writing cross-platform desktop applications using JavaScript (JS), HTML, and CSS. A vulnerability in versions prior to 18.0.0-beta.6, 17.2.0, 16.2.6, and 15.5.5 allows attackers who have control over a given apps update server / update storage to serve maliciously crafted update packages that pass the code signing validation check but contain malicious code in some components. This kind of attack would require significant privileges in a potential victim's own auto updating infrastructure and the ease of that attack entirely depends on the potential victim's infrastructure security. Electron versions 18.0.0-beta.6, 17.2.0, 16.2.6, and 15.5.5 contain a fix for this issue. There are no known workarounds.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2022-29257?

8 open source packages ship an affected version, including electron. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `electron` | npm | All versions | 15.5.0 |
| `electron` | npm | All versions | 15.5.0 |
| `electron` | npm | From 16.0.0 | 16.2.0 |
| `electron` | npm | From 16.0.0 | 16.2.0 |
| `electron` | npm | From 17.0.0 | 17.2.0 |
| `electron` | npm | From 17.0.0 | 17.2.0 |
| `electron` | npm | From 18.0.0-beta.1 | 18.0.0-beta.6 |
| `electron` | npm | From 18.0.0-beta.1 | 18.0.0-beta.6 |

Products: Electronjs Electron.

## How do I fix CVE-2022-29257?

Upgrade electron to a fixed version for your release line: 15.5.0, 16.2.0, 17.2.0 or 18.0.0-beta.6.

## Is CVE-2022-29257 being exploited?

There is no known exploitation of CVE-2022-29257 in the wild and no public exploit code.

## Other vulnerabilities in Electronjs Electron

- [CVE-2017-16151](https://insights.sbomify.com/CVE-2017-16151/): Chromium Remote Code Execution in electron (critical 9.8)
- [CVE-2018-1000118](https://insights.sbomify.com/CVE-2018-1000118/): Electron protocol handler browser vulnerable to Command Injection (high 8.8)
- [CVE-2026-34780](https://insights.sbomify.com/CVE-2026-34780/): Electron: Context Isolation bypass via contextBridge VideoFrame transfer (high 8.4)
- [CVE-2026-102676](https://insights.sbomify.com/CVE-2026-102676/): Electron: <webview> can enable Node.js integration in Web Workers despite embedder restrictions (high 8.3)
- [CVE-2026-102673](https://insights.sbomify.com/CVE-2026-102673/): Electron drops inherited HTML sandbox restrictions for popups opened through OpenURLFromTab (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-29257 and fix it if it is affected.

What it is: CVE-2022-29257 is a medium-severity code injection vulnerability in Electronjs Electron, published on 13 Jun 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-29257 in the wild and no public exploit code.

Affected packages and fixed versions:
- electron (npm): affected all versions; fixed in 15.5.0
- electron (npm): affected all versions; fixed in 15.5.0
- electron (npm): affected from 16.0.0; fixed in 16.2.0
- electron (npm): affected from 16.0.0; fixed in 16.2.0
- electron (npm): affected from 17.0.0; fixed in 17.2.0
- electron (npm): affected from 17.0.0; fixed in 17.2.0
- electron (npm): affected from 18.0.0-beta.1; fixed in 18.0.0-beta.6
- electron (npm): affected from 18.0.0-beta.1; fixed in 18.0.0-beta.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-29257/ (Markdown: https://insights.sbomify.com/CVE-2022-29257/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-29257
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-29257
- OSV: https://osv.dev/vulnerability/CVE-2022-29257

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-29257/
Summaries are generated and may contain mistakes; the official description above is the record.
