# CVE-2022-29265: Improper Restriction of XML External Entity References in Multiple Components

> Attackers can exploit XML External Entity vulnerabilities in Apache NiFi to read sensitive files or cause denial of service via malicious XML documents.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Apr 2022
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-nifi-2022-29265, GHSA-wc97-7623-rxwx

## What is CVE-2022-29265?

CVE-2022-29265 is a high-severity vulnerability in Apache Nifi, published on 30 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Multiple components in Apache NiFi 0.0.1 to 1.16.0 do not restrict XML External Entity references in the default configuration. The Standard Content Viewer service attempts to resolve XML External Entity references when viewing formatted XML files. The following Processors attempt to resolve XML External Entity references when configured with default property values: - EvaluateXPath - EvaluateXQuery - ValidateXml Apache NiFi flow configurations that include these Processors are vulnerable to malicious XML documents that contain Document Type Declarations with XML External Entity references. The resolution disables Document Type Declarations in the default configuration for these Processors, and disallows XML External Entity resolution in standard services.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2022-29265?

3 open source packages ship an affected version, including org.apache.nifi:nifi and nifi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.nifi:nifi` | Maven | From 0.0.1 | 1.16.1 |
| `org.apache.nifi:nifi` | Maven | From 0.0.1 | 1.16.1 |
| `nifi` | Bitnami | From 0.0.1 to 1.16.0 | None |

Products: Apache Nifi.

## How do I fix CVE-2022-29265?

Upgrade org.apache.nifi:nifi to 1.16.1 or later.

## Is CVE-2022-29265 being exploited?

There is no known exploitation of CVE-2022-29265 in the wild and no public exploit code.

## Other vulnerabilities in Apache Nifi

- [CVE-2018-1309](https://insights.sbomify.com/CVE-2018-1309/): Improper Restriction of XML External Entity Reference in Apache NiFi (critical 9.8)
- [CVE-2017-15697](https://insights.sbomify.com/CVE-2017-15697/): Apache NiFi XSS issue in context path handling (critical 9.8)
- [CVE-2017-5636](https://insights.sbomify.com/CVE-2017-5636/): Injection in Apache NiFi (critical 9.8)
- [CVE-2026-68981](https://insights.sbomify.com/CVE-2026-68981/): Apache NiFi: Uncontrolled Resource Consumption through Decompression of HTTP Requests (high 8.8)
- [CVE-2023-36542](https://insights.sbomify.com/CVE-2023-36542/): Apache NiFi: Potential Code Injection with Properties Referencing Remote Resources (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-29265 and fix it if it is affected.

What it is: CVE-2022-29265 is a high-severity vulnerability in Apache Nifi, published on 30 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-29265 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.nifi:nifi (Maven): affected from 0.0.1; fixed in 1.16.1
- org.apache.nifi:nifi (Maven): affected from 0.0.1; fixed in 1.16.1
- nifi (Bitnami): affected from 0.0.1 up to 1.16.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-29265/ (Markdown: https://insights.sbomify.com/CVE-2022-29265/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-29265
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-29265
- OSV: https://osv.dev/vulnerability/CVE-2022-29265

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-29265/
Summaries are generated and may contain mistakes; the official description above is the record.
