{"answers":{"affected":"2 open source packages ship an affected version, including notrinos/notrinos-erp. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-2927 in the wild and no public exploit code.","fix":"Upgrade notrinos/notrinos-erp to 0.7 or later.","what":"CVE-2022-2927 is a high-severity vulnerability in notrinos/notrinoserp, published on 22 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-2927 and fix it if it is affected.\n\nWhat it is: CVE-2022-2927 is a high-severity vulnerability in notrinos/notrinoserp, published on 22 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-2927 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- notrinos/notrinos-erp (Packagist): affected all versions; fixed in 0.7\n- notrinos/notrinos-erp (Packagist): affected all versions; fixed in 0.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-2927/ (Markdown: https://insights.sbomify.com/CVE-2022-2927/index.md)","id":"CVE-2022-2927","markdown":"https://insights.sbomify.com/CVE-2022-2927/index.md","name":"CVE-2022-2927","record":{"aliases":["GHSA-qhm8-69qh-g76j"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"ERP web application","requires_auth":"none","summary":"Weak password requirements in Notrinos ERP allow attackers to guess credentials and take over user accounts.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"notrinoserp","vendor":"notrinos"}],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L","version":"3.0"},"cwes":[{"id":"CWE-521","name":"Weak Password Requirements"}],"description":"Weak Password Requirements in GitHub repository notrinos/notrinoserp prior to 0.7.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Weak Password Requirements in notrinos/notrinoserp","id":"CVE-2022-2927","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"weak_cryptography","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"An option refcount overflow exists in dhcpd","id":"CVE-2022-2928"},"packages":[{"ecosystem":"Packagist","fixed":["0.7"],"introduced":["0"],"last_affected":[],"package":"notrinos/notrinos-erp","purl":null,"source":"GHSA-qhm8-69qh-g76j"},{"ecosystem":"Packagist","fixed":["0.7"],"introduced":["0"],"last_affected":[],"package":"notrinos/notrinos-erp","purl":"pkg:composer/notrinos/notrinos-erp","source":"GHSA-qhm8-69qh-g76j"}],"prev":{"headline":"Download Manager \u003c 3.2.55 - Admin+ Arbitrary File/Folder Access via Path Traversal","id":"CVE-2022-2926"},"products":["notrinos/notrinoserp"],"published":"2022-08-22","related":[{"cvss_score":8.8,"headline":"NotrinosERP vulnerable to SQL Injection","id":"CVE-2023-24788","kev_date_added":null,"published":"2023-03-23"},{"cvss_score":8.8,"headline":"Exposure of Private Personal Information to an Unauthorized Actor in notrinos/notrinoserp","id":"CVE-2022-2921","kev_date_added":null,"published":"2022-08-21"},{"cvss_score":6.4,"headline":"Improper Restriction of Rendered UI Layers or Frames in notrinos/notrinoserp","id":"CVE-2022-2965","kev_date_added":null,"published":"2022-08-23"},{"cvss_score":4.6,"headline":"Cross-site Scripting (XSS) - Stored in notrinos/notrinoserp","id":"CVE-2022-2871","kev_date_added":null,"published":"2022-08-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["notrinos"]},"summary":"Weak password requirements in Notrinos ERP allow attackers to guess credentials and take over user accounts.","url":"https://insights.sbomify.com/CVE-2022-2927/"}