# CVE-2022-2927: Weak Password Requirements in notrinos/notrinoserp

> Weak password requirements in Notrinos ERP allow attackers to guess credentials and take over user accounts.

- **Severity:** High 7.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Aug 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-qhm8-69qh-g76j

## What is CVE-2022-2927?

CVE-2022-2927 is a high-severity vulnerability in notrinos/notrinoserp, published on 22 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Weak Password Requirements in GitHub repository notrinos/notrinoserp prior to 0.7.

Weakness: CWE-521 (Weak Password Requirements)

## Which versions are affected by CVE-2022-2927?

2 open source packages ship an affected version, including notrinos/notrinos-erp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `notrinos/notrinos-erp` | Packagist | All versions | 0.7 |
| `notrinos/notrinos-erp` | Packagist | All versions | 0.7 |

Products: Notrinos Notrinoserp.

## How do I fix CVE-2022-2927?

Upgrade notrinos/notrinos-erp to 0.7 or later.

## Is CVE-2022-2927 being exploited?

There is no known exploitation of CVE-2022-2927 in the wild and no public exploit code.

## Other vulnerabilities in notrinos/notrinoserp

- [CVE-2023-24788](https://insights.sbomify.com/CVE-2023-24788/): NotrinosERP vulnerable to SQL Injection (high 8.8)
- [CVE-2022-2921](https://insights.sbomify.com/CVE-2022-2921/): Exposure of Private Personal Information to an Unauthorized Actor in notrinos/notrinoserp (high 8.8)
- [CVE-2022-2965](https://insights.sbomify.com/CVE-2022-2965/): Improper Restriction of Rendered UI Layers or Frames in notrinos/notrinoserp (medium 6.4)
- [CVE-2022-2871](https://insights.sbomify.com/CVE-2022-2871/): Cross-site Scripting (XSS) - Stored in notrinos/notrinoserp (medium 4.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-2927 and fix it if it is affected.

What it is: CVE-2022-2927 is a high-severity vulnerability in notrinos/notrinoserp, published on 22 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-2927 in the wild and no public exploit code.

Affected packages and fixed versions:
- notrinos/notrinos-erp (Packagist): affected all versions; fixed in 0.7
- notrinos/notrinos-erp (Packagist): affected all versions; fixed in 0.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-2927/ (Markdown: https://insights.sbomify.com/CVE-2022-2927/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-2927
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-2927
- OSV: https://osv.dev/vulnerability/CVE-2022-2927

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-2927/
Summaries are generated and may contain mistakes; the official description above is the record.
