CVE-2022-2931 Denial of service in GitLab
Attackers can cause high CPU usage and denial of service by adding malformed content to GitLab issue descriptions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-2931?
CVE-2022-2931 is a high-severity denial of service vulnerability in Gitlab Gitlab, published on 17 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A potential DOS vulnerability was discovered in GitLab CE/EE affecting all versions before 15.1.6, all versions starting from 15.2 before 15.2.4, all versions starting from 15.3 before 15.3.2. Malformed content added to the issue description could have been used to trigger high CPU usage.
Weakness: CWE-400
Which versions are affected by CVE-2022-2931?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | All versions | 15.1.6, 15.2.4, 15.3.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2022-2931?
Upgrade gitlab to a fixed version for your release line: 15.1.6, 15.2.4 or 15.3.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2022-2931 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-2931 exists.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2022-2931, GHSA-p95h-29v8-j2h6, UBUNTU-CVE-2022-2931.