# CVE-2022-29405: Apache Archiva Arbitrary user password reset vulnerability

> Any registered user can reset passwords for other users, leading to account takeover in Apache Archiva.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 May 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-5hqc-x78w-3cmw

## What is CVE-2022-29405?

CVE-2022-29405 is a medium-severity authentication bypass vulnerability in Apache Archiva, published on 25 May 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Apache Archiva, any registered user can reset password for any users. This is fixed in Archiva 2.2.8

## Which versions are affected by CVE-2022-29405?

2 open source packages ship an affected version, including org.apache.archiva:archiva. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.archiva:archiva` | Maven | All versions | 2.2.8 |
| `org.apache.archiva:archiva` | Maven | All versions | 2.2.8 |

Products: Apache Archiva.

## How do I fix CVE-2022-29405?

Upgrade org.apache.archiva:archiva to 2.2.8 or later.

## Is CVE-2022-29405 being exploited?

There is no known exploitation of CVE-2022-29405 in the wild and no public exploit code.

## Other vulnerabilities in Apache Archiva

- [CVE-2013-2251](https://insights.sbomify.com/CVE-2013-2251/): Apache Struts Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2016-4469](https://insights.sbomify.com/CVE-2016-4469/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2017-5657](https://insights.sbomify.com/CVE-2017-5657/): Apache Archiva vulnerable to Cross Site Request Forgery (high 8.0)
- [CVE-2024-27138](https://insights.sbomify.com/CVE-2024-27138/): Apache Archiva: disabling user registration is not effective (high 7.5)
- [CVE-2024-27139](https://insights.sbomify.com/CVE-2024-27139/): Apache Archiva: incorrect authentication potentially leading to account takeover (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-29405 and fix it if it is affected.

What it is: CVE-2022-29405 is a medium-severity authentication bypass vulnerability in Apache Archiva, published on 25 May 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-29405 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.archiva:archiva (Maven): affected all versions; fixed in 2.2.8
- org.apache.archiva:archiva (Maven): affected all versions; fixed in 2.2.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-29405/ (Markdown: https://insights.sbomify.com/CVE-2022-29405/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-29405
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-29405
- OSV: https://osv.dev/vulnerability/CVE-2022-29405

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-29405/
Summaries are generated and may contain mistakes; the official description above is the record.
