{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-29527 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2022-29527 is a high-severity vulnerability in n/a, published on 20 Apr 2022. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-29527 and fix it if it is affected.\n\nWhat it is: CVE-2022-29527 is a high-severity vulnerability in n/a, published on 20 Apr 2022. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-29527 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-29527/ (Markdown: https://insights.sbomify.com/CVE-2022-29527/index.md)","id":"CVE-2022-29527","markdown":"https://insights.sbomify.com/CVE-2022-29527/index.md","name":"CVE-2022-29527","record":{"aliases":["GHSA-87pw-p9qx-p46w","SUSE-SU-2022:1510-1","SUSE-SU-2022:3654-1","openSUSE-SU-2024:12012-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"AWS SSM Agent","requires_auth":"low_privilege","summary":"Local attackers can escalate privileges to root by exploiting a race condition that creates a world-writable sudoers file in the AWS SSM Agent.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"amazon_ssm_agent","vendor":"amazon"}],"cvss":{"score":7,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-732","name":"Incorrect Permission Assignment for Critical Resource"},{"id":"CWE-362","name":"Concurrent Execution using Shared Resource with Improper Synchronization"}],"description":"Amazon AWS amazon-ssm-agent before 3.1.1208.0 creates a world-writable sudoers file, which allows local attackers to inject Sudo rules and escalate privileges to root. This occurs in certain situations involving a race condition.","ecosystems":["SUSE:Linux Enterprise Module for Public Cloud 12","SUSE:Linux Enterprise Module for Public Cloud 15","SUSE:Linux Enterprise Module for Public Cloud 15 SP1","SUSE:Linux Enterprise Module for Public Cloud 15 SP2","SUSE:Linux Enterprise Module for Public Cloud 15 SP3","openSUSE:Leap 15.3","openSUSE:Leap 15.4","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Privilege escalation in n/a","id":"CVE-2022-29527","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"privilege_escalation","year":"2022"},"n_packages":8,"n_references":3,"next":{"headline":"An issue was discovered in MISP before 2.4.158.","id":"CVE-2022-29528"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Public Cloud 12","fixed":["3.1.1260.0-4.27.2"],"introduced":["0"],"last_affected":[],"package":"amazon-ssm-agent","purl":"pkg:rpm/suse/amazon-ssm-agent\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Public%20Cloud%2012","source":"SUSE-SU-2022:3654-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Public Cloud 15","fixed":["3.1.1260.0-150000.5.9.2"],"introduced":["0"],"last_affected":[],"package":"amazon-ssm-agent","purl":"pkg:rpm/suse/amazon-ssm-agent\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Public%20Cloud%2015","source":"SUSE-SU-2022:1510-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Public Cloud 15 SP1","fixed":["3.1.1260.0-150000.5.9.2"],"introduced":["0"],"last_affected":[],"package":"amazon-ssm-agent","purl":"pkg:rpm/suse/amazon-ssm-agent\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Public%20Cloud%2015%20SP1","source":"SUSE-SU-2022:1510-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Public Cloud 15 SP2","fixed":["3.1.1260.0-150000.5.9.2"],"introduced":["0"],"last_affected":[],"package":"amazon-ssm-agent","purl":"pkg:rpm/suse/amazon-ssm-agent\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Public%20Cloud%2015%20SP2","source":"SUSE-SU-2022:1510-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Public Cloud 15 SP3","fixed":["3.1.1260.0-150000.5.9.2"],"introduced":["0"],"last_affected":[],"package":"amazon-ssm-agent","purl":"pkg:rpm/suse/amazon-ssm-agent\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Public%20Cloud%2015%20SP3","source":"SUSE-SU-2022:1510-1"},{"ecosystem":"openSUSE:Leap 15.3","fixed":["3.1.1260.0-150000.5.9.2"],"introduced":["0"],"last_affected":[],"package":"amazon-ssm-agent","purl":"pkg:rpm/opensuse/amazon-ssm-agent\u0026distro=openSUSE%20Leap%2015.3","source":"SUSE-SU-2022:1510-1"},{"ecosystem":"openSUSE:Leap 15.4","fixed":["3.1.1260.0-150000.5.9.2"],"introduced":["0"],"last_affected":[],"package":"amazon-ssm-agent","purl":"pkg:rpm/opensuse/amazon-ssm-agent\u0026distro=openSUSE%20Leap%2015.4","source":"SUSE-SU-2022:1510-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["3.1.1260.0-1.1"],"introduced":["0"],"last_affected":[],"package":"amazon-ssm-agent","purl":"pkg:rpm/opensuse/amazon-ssm-agent\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:12012-1"}],"prev":{"headline":"golang.org/x/sys/unix has Incorrect privilege reporting in syscall","id":"CVE-2022-29526"},"products":["n/a"],"published":"2022-04-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"Local attackers can escalate privileges to root by exploiting a race condition that creates a world-writable sudoers file in the AWS SSM Agent.","url":"https://insights.sbomify.com/CVE-2022-29527/"}