# CVE-2022-29546: OutOfMemory Exception by specifically crafted processing instruction in NekoHtml Parser

> An attacker can cause a denial of service by sending crafted Processing Instruction data to the HtmlUnit NekoHtml Parser, leading to excessive heap memory consumption.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Apr 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-6jmm-mp6w-4rrg

## What is CVE-2022-29546?

CVE-2022-29546 is a high-severity denial of service vulnerability in n/a, published on 25 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

HtmlUnit NekoHtml Parser before 2.61.0 suffers from a denial of service vulnerability. Crafted input associated with the parsing of Processing Instruction (PI) data leads to heap memory consumption. This is similar to CVE-2022-28366 but affects a much later version of the product.

## Which versions are affected by CVE-2022-29546?

2 open source packages ship an affected version, including net.sourceforge.htmlunit:neko-htmlunit. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `net.sourceforge.htmlunit:neko-htmlunit` | Maven | All versions | 2.61.0 |
| `net.sourceforge.htmlunit:neko-htmlunit` | Maven | All versions | 2.61.0 |

Products: Htmlunit Htmlunit.

## How do I fix CVE-2022-29546?

Upgrade net.sourceforge.htmlunit:neko-htmlunit to 2.61.0 or later.

## Is CVE-2022-29546 being exploited?

There is no known exploitation of CVE-2022-29546 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-49093](https://insights.sbomify.com/CVE-2023-49093/): HtmlUnit vulnerable to Remote Code Execution (RCE) via XSTL (critical 9.8)
- [CVE-2023-26119](https://insights.sbomify.com/CVE-2023-26119/): HtmlUnit Code Injection vulnerability (critical 9.8)
- [CVE-2023-2798](https://insights.sbomify.com/CVE-2023-2798/): Denial of service in HtmlUnit (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-29546 and fix it if it is affected.

What it is: CVE-2022-29546 is a high-severity denial of service vulnerability in n/a, published on 25 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-29546 in the wild and no public exploit code.

Affected packages and fixed versions:
- net.sourceforge.htmlunit:neko-htmlunit (Maven): affected all versions; fixed in 2.61.0
- net.sourceforge.htmlunit:neko-htmlunit (Maven): affected all versions; fixed in 2.61.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-29546/ (Markdown: https://insights.sbomify.com/CVE-2022-29546/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-29546
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-29546
- OSV: https://osv.dev/vulnerability/CVE-2022-29546

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-29546/
Summaries are generated and may contain mistakes; the official description above is the record.
