# CVE-2022-29567: Possible information disclosure inside TreeGrid component with default data provider

> An attacker can potentially read sensitive data from the server via the TreeGrid component's default client-side key generation mechanism.

- **Severity:** Medium 5.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 May 2022
- **Updated:** 14 Sep 2026
- **Also known as:** GHSA-qfr3-323w-qv27

## What is CVE-2022-29567?

CVE-2022-29567 is a medium-severity vulnerability in vaadin, published on 24 May 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

The default configuration of a TreeGrid component uses Object::toString as a key on the client-side and server communication in Vaadin 14.8.5 through 14.8.9, 22.0.6 through 22.0.14, 23.0.0.beta2 through 23.0.8 and 23.1.0.alpha1 through 23.1.0.alpha4, resulting in potential information disclosure of values that should not be available on the client-side.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2022-29567?

12 open source packages ship an affected version, including com.vaadin:vaadin and com.vaadin:vaadin-grid-flow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.vaadin:vaadin` | Maven | From 14.8.5 | 14.8.10 |
| `com.vaadin:vaadin` | Maven | From 14.8.5 | 14.8.10 |
| `com.vaadin:vaadin` | Maven | From 22.0.6 | 22.0.15 |
| `com.vaadin:vaadin` | Maven | From 22.0.6 | 22.0.15 |
| `com.vaadin:vaadin` | Maven | From 23.0.0 | 23.0.9 |
| `com.vaadin:vaadin` | Maven | From 23.0.0 | 23.0.9 |
| `com.vaadin:vaadin-grid-flow` | Maven | From 14.8.5 | 14.8.10 |
| `com.vaadin:vaadin-grid-flow` | Maven | From 14.8.5 | 14.8.10 |
| `com.vaadin:vaadin-grid-flow` | Maven | From 22.0.6 | 22.0.15 |
| `com.vaadin:vaadin-grid-flow` | Maven | From 22.0.6 | 22.0.15 |
| `com.vaadin:vaadin-grid-flow` | Maven | From 23.0.0.beta2 | 23.0.9 |
| `com.vaadin:vaadin-grid-flow` | Maven | From 23.0.0.beta2 | 23.0.9 |

Products: Vaadin Vaadin.

## How do I fix CVE-2022-29567?

Upgrade com.vaadin:vaadin to a fixed version for your release line: 14.8.10, 22.0.15 or 23.0.9.

## Is CVE-2022-29567 being exploited?

There is no known exploitation of CVE-2022-29567 in the wild and no public exploit code.

## Other vulnerabilities in vaadin

- [CVE-2021-31409](https://insights.sbomify.com/CVE-2021-31409/): Server session is not invalidated when logout() helper method of Authentication module is used in Vaadin 18-19 (high 7.5)
- [CVE-2020-36320](https://insights.sbomify.com/CVE-2020-36320/): Regular expression Denial of Service (ReDoS) in EmailValidator class in Vaadin 7 (high 7.5)
- [CVE-2021-33611](https://insights.sbomify.com/CVE-2021-33611/): Reflected cross-site scripting in vaadin-menu-bar webjar resources in Vaadin 14 (medium 6.1)
- [CVE-2023-25499](https://insights.sbomify.com/CVE-2023-25499/): Possible information disclosure in non visible components (medium 5.7)
- [CVE-2019-25028](https://insights.sbomify.com/CVE-2019-25028/): Stored cross-site scripting in Grid component in Vaadin 7 and 8 (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-29567 and fix it if it is affected.

What it is: CVE-2022-29567 is a medium-severity vulnerability in vaadin, published on 24 May 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-29567 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.vaadin:vaadin (Maven): affected from 14.8.5; fixed in 14.8.10
- com.vaadin:vaadin (Maven): affected from 14.8.5; fixed in 14.8.10
- com.vaadin:vaadin (Maven): affected from 22.0.6; fixed in 22.0.15
- com.vaadin:vaadin (Maven): affected from 22.0.6; fixed in 22.0.15
- com.vaadin:vaadin (Maven): affected from 23.0.0; fixed in 23.0.9
- com.vaadin:vaadin (Maven): affected from 23.0.0; fixed in 23.0.9
- com.vaadin:vaadin-grid-flow (Maven): affected from 14.8.5; fixed in 14.8.10
- com.vaadin:vaadin-grid-flow (Maven): affected from 14.8.5; fixed in 14.8.10
- com.vaadin:vaadin-grid-flow (Maven): affected from 22.0.6; fixed in 22.0.15
- com.vaadin:vaadin-grid-flow (Maven): affected from 22.0.6; fixed in 22.0.15
- com.vaadin:vaadin-grid-flow (Maven): affected from 23.0.0.beta2; fixed in 23.0.9
- com.vaadin:vaadin-grid-flow (Maven): affected from 23.0.0.beta2; fixed in 23.0.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-29567/ (Markdown: https://insights.sbomify.com/CVE-2022-29567/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-29567
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-29567
- OSV: https://osv.dev/vulnerability/CVE-2022-29567

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-29567/
Summaries are generated and may contain mistakes; the official description above is the record.
