{"answers":{"affected":"2 open source packages ship an affected version, including org.owasp.antisamy:antisamy. It affects 3 products.","exploited":"There is no known exploitation of CVE-2022-29577 in the wild and no public exploit code.","fix":"Upgrade org.owasp.antisamy:antisamy to 1.6.7 or later.","what":"CVE-2022-29577 is a medium-severity cross-site scripting vulnerability in Oracle Enterprise Manager Base Platform, published on 21 Apr 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-29577 and fix it if it is affected.\n\nWhat it is: CVE-2022-29577 is a medium-severity cross-site scripting vulnerability in Oracle Enterprise Manager Base Platform, published on 21 Apr 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-29577 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.owasp.antisamy:antisamy (Maven): affected all versions; fixed in 1.6.7\n- org.owasp.antisamy:antisamy (Maven): affected all versions; fixed in 1.6.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-29577/ (Markdown: https://insights.sbomify.com/CVE-2022-29577/index.md)","id":"CVE-2022-29577","markdown":"https://insights.sbomify.com/CVE-2022-29577/index.md","name":"CVE-2022-29577","record":{"aliases":["GHSA-vp37-2f9p-3vr3","UBUNTU-CVE-2022-29577"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Java HTML sanitizer","requires_auth":"none","summary":"Attackers can execute arbitrary scripts via HTML tag smuggling in STYLE content due to improper encoding in the OWASP AntiSamy library.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"antisamy","vendor":"antisamy_project"},{"product":"enterprise_manager_base_platform","vendor":"oracle"},{"product":"weblogic_server","vendor":"oracle"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"OWASP AntiSamy before 1.6.7 allows XSS via HTML tag smuggling on STYLE content with crafted input. The output serializer does not properly encode the supposed Cascading Style Sheets (CSS) content. NOTE: this issue exists because of an incomplete fix for CVE-2022-28367.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":"2025-08-17","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2025-08-17T06:23:20Z","kind":"github_poc","ref":"https://github.com/shoucheng3/nahsra__antisamy_CVE-2022-29577_1-6-6-1","stars":0,"title":null}],"tier":"poc_unverified"},"has_fix":true,"headline":"Cross-site Scripting in OWASP AntiSamy","id":"CVE-2022-29577","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"oracle:enterprise_manager_base_platform","products":["oracle:enterprise_manager_base_platform","oracle:weblogic_server"],"type":"xss","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"Information disclosure in n/a","id":"CVE-2022-29578"},"packages":[{"ecosystem":"Maven","fixed":["1.6.7"],"introduced":["0"],"last_affected":[],"package":"org.owasp.antisamy:antisamy","purl":null,"source":"GHSA-vp37-2f9p-3vr3"},{"ecosystem":"Maven","fixed":["1.6.7"],"introduced":["0"],"last_affected":[],"package":"org.owasp.antisamy:antisamy","purl":"pkg:maven/org.owasp.antisamy/antisamy","source":"GHSA-vp37-2f9p-3vr3"}],"prev":{"headline":"Possible information disclosure inside TreeGrid component with default data provider","id":"CVE-2022-29567"},"products":["n/a"],"published":"2022-04-21","related":[{"cvss_score":7.5,"headline":"Denial of service in HtmlUnit-Neko","id":"CVE-2022-28366","kev_date_added":null,"published":"2022-04-21"},{"cvss_score":6.1,"headline":"AntiSamy malicious input can provoke XSS when preserving comments","id":"CVE-2024-23635","kev_date_added":null,"published":"2024-02-02"},{"cvss_score":6.1,"headline":"mXSS in AntiSamy","id":"CVE-2023-43643","kev_date_added":null,"published":"2023-10-09"},{"cvss_score":6.1,"headline":"Cross-site Scripting in OWASP AntiSamy","id":"CVE-2022-28367","kev_date_added":null,"published":"2022-04-21"},{"cvss_score":6.1,"headline":"Cross-site Scripting in OWASP AntiSamy","id":"CVE-2021-35043","kev_date_added":null,"published":"2021-07-19"},{"cvss_score":6.1,"headline":"OWASP AntiSamy Cross-site Scripting vulnerability","id":"CVE-2017-14735","kev_date_added":null,"published":"2017-09-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["n/a"]},"summary":"Attackers can execute arbitrary scripts via HTML tag smuggling in STYLE content due to improper encoding in the OWASP AntiSamy library.","url":"https://insights.sbomify.com/CVE-2022-29577/"}