# CVE-2022-29577: Cross-site Scripting in OWASP AntiSamy

> Attackers can execute arbitrary scripts via HTML tag smuggling in STYLE content due to improper encoding in the OWASP AntiSamy library.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Apr 2022
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-vp37-2f9p-3vr3, UBUNTU-CVE-2022-29577

## What is CVE-2022-29577?

CVE-2022-29577 is a medium-severity cross-site scripting vulnerability in Oracle Enterprise Manager Base Platform, published on 21 Apr 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

OWASP AntiSamy before 1.6.7 allows XSS via HTML tag smuggling on STYLE content with crafted input. The output serializer does not properly encode the supposed Cascading Style Sheets (CSS) content. NOTE: this issue exists because of an incomplete fix for CVE-2022-28367.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-29577?

2 open source packages ship an affected version, including org.owasp.antisamy:antisamy. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.owasp.antisamy:antisamy` | Maven | All versions | 1.6.7 |
| `org.owasp.antisamy:antisamy` | Maven | All versions | 1.6.7 |

Products: Antisamy Project Antisamy, Oracle Enterprise Manager Base Platform, Oracle Weblogic Server.

## How do I fix CVE-2022-29577?

Upgrade org.owasp.antisamy:antisamy to 1.6.7 or later.

## Is CVE-2022-29577 being exploited?

There is no known exploitation of CVE-2022-29577 in the wild and no public exploit code.

Public exploit code:

- https://github.com/shoucheng3/nahsra__antisamy_CVE-2022-29577_1-6-6-1 (github_poc): https://github.com/shoucheng3/nahsra__antisamy_CVE-2022-29577_1-6-6-1

## Other vulnerabilities in Oracle Enterprise Manager Base Platform

- [CVE-2022-28366](https://insights.sbomify.com/CVE-2022-28366/): Denial of service in HtmlUnit-Neko (high 7.5)
- [CVE-2024-23635](https://insights.sbomify.com/CVE-2024-23635/): AntiSamy malicious input can provoke XSS when preserving comments (medium 6.1)
- [CVE-2023-43643](https://insights.sbomify.com/CVE-2023-43643/): mXSS in AntiSamy (medium 6.1)
- [CVE-2022-28367](https://insights.sbomify.com/CVE-2022-28367/): Cross-site Scripting in OWASP AntiSamy (medium 6.1)
- [CVE-2021-35043](https://insights.sbomify.com/CVE-2021-35043/): Cross-site Scripting in OWASP AntiSamy (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-29577 and fix it if it is affected.

What it is: CVE-2022-29577 is a medium-severity cross-site scripting vulnerability in Oracle Enterprise Manager Base Platform, published on 21 Apr 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-29577 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.owasp.antisamy:antisamy (Maven): affected all versions; fixed in 1.6.7
- org.owasp.antisamy:antisamy (Maven): affected all versions; fixed in 1.6.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-29577/ (Markdown: https://insights.sbomify.com/CVE-2022-29577/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-29577
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-29577
- OSV: https://osv.dev/vulnerability/CVE-2022-29577

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-29577/
Summaries are generated and may contain mistakes; the official description above is the record.
