# CVE-2022-29631: Server-Side Request Forgery in Jodd HTTP

> Attackers can perform Server-Side Request Forgery via CRLF injection in Jodd HTTP library requests, potentially accessing internal resources.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jun 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-pp3c-cf6j-m3ff

## What is CVE-2022-29631?

CVE-2022-29631 is a high-severity server-side request forgery vulnerability in n/a, published on 6 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Jodd HTTP v6.0.9 was discovered to contain multiple CLRF injection vulnerabilities via the components jodd.http.HttpRequest#set and `jodd.http.HttpRequest#send. These vulnerabilities allow attackers to execute Server-Side Request Forgery (SSRF) via a crafted TCP payload.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2022-29631?

2 open source packages ship an affected version, including org.jodd:jodd-http. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jodd:jodd-http` | Maven | From 5.0.0 | 6.2.1 |
| `org.jodd:jodd-http` | Maven | From 5.0.0 | 6.2.1 |

Products: Jodd Jodd Http.

## How do I fix CVE-2022-29631?

Upgrade org.jodd:jodd-http to 6.2.1 or later.

## Is CVE-2022-29631 being exploited?

There is no known exploitation of CVE-2022-29631 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-29631 and fix it if it is affected.

What it is: CVE-2022-29631 is a high-severity server-side request forgery vulnerability in n/a, published on 6 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-29631 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jodd:jodd-http (Maven): affected from 5.0.0; fixed in 6.2.1
- org.jodd:jodd-http (Maven): affected from 5.0.0; fixed in 6.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-29631/ (Markdown: https://insights.sbomify.com/CVE-2022-29631/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-29631
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-29631
- OSV: https://osv.dev/vulnerability/CVE-2022-29631

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-29631/
Summaries are generated and may contain mistakes; the official description above is the record.
