# CVE-2022-29712: Command injection in librenms

> Attackers can execute arbitrary commands on the server via vulnerable parameters in LibreNMS, requiring immediate upgrade.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 May 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-23f2-vgr6-fwv7

## What is CVE-2022-29712?

CVE-2022-29712 is a critical command injection vulnerability in Librenms Librenms, published on 31 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

LibreNMS v22.3.0 was discovered to contain multiple command injection vulnerabilities via the service_ip, hostname, and service_param parameters.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2022-29712?

2 open source packages ship an affected version, including librenms/librenms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `librenms/librenms` | Packagist | All versions | 22.4.0 |
| `librenms/librenms` | Packagist | All versions | 22.4.0 |

Products: Librenms Librenms.

## How do I fix CVE-2022-29712?

Upgrade librenms/librenms to 22.4.0 or later.

## Is CVE-2022-29712 being exploited?

There is no known exploitation of CVE-2022-29712 in the wild and no public exploit code.

## Other vulnerabilities in Librenms Librenms

- [CVE-2023-4982](https://insights.sbomify.com/CVE-2023-4982/): Cross-site Scripting (XSS) - Stored in librenms/librenms (critical 9.8)
- [CVE-2021-44278](https://insights.sbomify.com/CVE-2021-44278/): Path traversal in librenms/librenms (critical 9.8)
- [CVE-2019-10665](https://insights.sbomify.com/CVE-2019-10665/): LibreNMS Information Disclosure (critical 9.8)
- [CVE-2018-20434](https://insights.sbomify.com/CVE-2018-20434/): LibreNMS arbitrary OS commands execution (critical 9.8)
- [CVE-2026-26988](https://insights.sbomify.com/CVE-2026-26988/): LibreNMS: SQL Injection in ajax_table.php spreads through a covert data stream (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-29712 and fix it if it is affected.

What it is: CVE-2022-29712 is a critical command injection vulnerability in Librenms Librenms, published on 31 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-29712 in the wild and no public exploit code.

Affected packages and fixed versions:
- librenms/librenms (Packagist): affected all versions; fixed in 22.4.0
- librenms/librenms (Packagist): affected all versions; fixed in 22.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-29712/ (Markdown: https://insights.sbomify.com/CVE-2022-29712/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-29712
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-29712
- OSV: https://osv.dev/vulnerability/CVE-2022-29712

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-29712/
Summaries are generated and may contain mistakes; the official description above is the record.
