# CVE-2022-29718: Open redirect in caddy

> An open redirect in Caddy allows attackers to redirect users to malicious sites via crafted links, potentially facilitating phishing attacks.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Jun 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-2927-hv3p-f3vp, openSUSE-SU-2022:10007-1, openSUSE-SU-2024:12132-1

## What is CVE-2022-29718?

CVE-2022-29718 is a medium-severity vulnerability in n/a, published on 2 Jun 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Caddy v2.4 was discovered to contain an open redirect vulnerability. A remote unauthenticated attacker may exploit this vulnerability to redirect users to arbitrary web URLs by tricking the victim users to click on crafted links.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2022-29718?

4 open source packages ship an affected version, including github.com/caddyserver/caddy and github.com/caddyserver/caddy/v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/caddyserver/caddy` | Go | All versions | 2.5.0 |
| `github.com/caddyserver/caddy` | Go | All versions | 2.5.0 |
| `github.com/caddyserver/caddy/v2` | Go | All versions | 2.5.0 |
| `github.com/caddyserver/caddy/v2` | Go | All versions | 2.5.0 |
| `caddy` | SUSE:Package Hub 15 SP4 | All versions | 2.5.1-bp154.2.5.1 |
| `caddy` | openSUSE:Leap 15.4 | All versions | 2.5.1-bp154.2.5.1 |
| `caddy` | openSUSE:Tumbleweed | All versions | 2.5.1-2.1 |

Products: Caddyserver Caddy.

## How do I fix CVE-2022-29718?

Upgrade github.com/caddyserver/caddy to 2.5.0 or later.

## Is CVE-2022-29718 being exploited?

There is no known exploitation of CVE-2022-29718 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-21246](https://insights.sbomify.com/CVE-2018-21246/): Caddy vulnerable to Authentication Bypass due to mishandling of TLS client authentication (critical 9.8)
- [CVE-2026-27590](https://insights.sbomify.com/CVE-2026-27590/): Caddy: Unicode case-folding length expansion causes incorrect split_path index in FastCGI transport (high 8.9)
- [CVE-2026-27586](https://insights.sbomify.com/CVE-2026-27586/): Caddy's mTLS client authentication silently fails open when CA certificate file is missing or malformed (high 8.8)
- [CVE-2026-45135](https://insights.sbomify.com/CVE-2026-45135/): Caddy: Unsafe Unicode Handling in FastCGI splitPos Allows Execution of Non-PHP Files (high 8.1)
- [CVE-2026-52845](https://insights.sbomify.com/CVE-2026-52845/): Caddy: FastCGI header normalization bypass in `forward_auth copy_headers` (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-29718 and fix it if it is affected.

What it is: CVE-2022-29718 is a medium-severity vulnerability in n/a, published on 2 Jun 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-29718 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/caddyserver/caddy (Go): affected all versions; fixed in 2.5.0
- github.com/caddyserver/caddy (Go): affected all versions; fixed in 2.5.0
- github.com/caddyserver/caddy/v2 (Go): affected all versions; fixed in 2.5.0
- github.com/caddyserver/caddy/v2 (Go): affected all versions; fixed in 2.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-29718/ (Markdown: https://insights.sbomify.com/CVE-2022-29718/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-29718
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-29718
- OSV: https://osv.dev/vulnerability/CVE-2022-29718

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-29718/
Summaries are generated and may contain mistakes; the official description above is the record.
